ПРИКЛАДИ РОБОТИ З неперіодичних константою

Значення неперіодичної константи можна отримувати і змінювати, звертаючись до неї по іменіКонстантаИдентификаторКонстантыабо вживаючи методи ПолучітьАтрібут і УстановітьАтрібут

Приклад 1Вивести назву організації

процедура Виконати () / / Повязана з кнопкою Пуск Повідомити (КонстантаНазваниеОрганизации) / / Надрукували, наприклад, АТ ТрансМаш

/ / То ж повідомлення виведе виклик Сообщить(КонстантаПолучитьАтрибут(&quotНазваниеОрганизации&quot))

КонецПроцедури / / Виконати

Приклад 2Створити код, що змінює значення неперіодичної константи НазваніеОрганізаціі з колишнього на АТ Простір, а потім відновлює стару назву

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем новоеНазваніе, староеНазваніе, відповідь

новоеНазваніе = АТ Простір;

староеНазваніе = КонстантаНазваниеОрганизации ОчістітьОкноСообщеній ()

Повідомити (Колишня назва організації: + староеНазваніе)

відповідь = Питання (Змінити назву організації на + новоеНазваніе + ?”, Так + Ні) якщо відповідь = Так тоді / / Натиснуто кнопка Так

КонстантаНазваниеОрганизации = новоеНазваніе Повідомити (Назва організації після зміни: +

КонстантаНазваниеОрганизации)

/ / Відновимо стара назва константи Попередження (Назва організації буде відновлено”) КонстантаНазваниеОрганизации = староеНазваніе

інакше / / Обрана кнопка Ні

Попередження (Назва організації залишилося без змін”) КонецЕсли

КонецПроцедури / / Виконати

Зауваження:

1 • Замість присвоювання

КонстантаНазваниеОрганизации = новоеНазваніе можна використовувати метод КонстантаУстановитьАтрибут(&quotНазваниеОрганизации&quot, новоеНазваніе)

2 Вбудована функція Питання виведе при виконанні програми вікно з кнопкам

Так і Ні (рис 129)

Рис 129 Вікно, що породжується вбудованою функцією Питання

Імена кнопок визначаються другим параметром функції, заданих у вигляді рядка Так + Ні. Функція Питання поверне рядок зі значенням, що збігається з імям натиснутою кнопки

3 У разі громіздких операторів або виразів їх слід розміщувати на декількох рядках Символи переносу при цьому не вживаються Наприклад:

Повідомити (Назва організації після зміни: + КонстантаНазваниеОрганизации)

4 Приклад показує, що потрібно вкрай акуратно працювати з довідниками взагалі і з константами зокрема Досить кілька рядків недбалого коду, щоб спотворити дані і зробити в результаті непрацездатною всю систему У нашому прикладі ми уникли негативних наслідків, додавши код, який відновлює колишнє значення зміненої константи

Приклад 3Виводиться список неперіодичних констант, що мають синонім, у вікно повідомлень

Перегляд списку констант можна організувати, написавши програму, що виводить,

наприклад, у вікно повідомлень ідентифікатор, синонім константи і її значення Розмістимо цей код, як завжди, у процедурі Виконати модуля обробки Проба:

/ / Процедура виведення списку неперіодичних, визначених у конфігурації констант

процедура Виконати ()

//

Повязана з кнопкою Пуск обробки Проба

перем всегоКонстант перем ідеї, сін, значен

//

Число констант в конфігурації

ОчістітьОкноСообщеній () / / Очищаємо вікно повідомлень

всегоКонстант = МетаданниеКонстанта () для ін = 1 по всегоКонстант цикл

якщо МетаданниеКонстанта (ін) Періодичний = 1 тоді

продовжити / / Значення періодичних констант виводяться КонецЕсли

сін = МетаданниеКонстанта (ії) Синонім

/ / Виводимо повідомлення про константи, для яких заданий синонім якщо ПустоеЗначеніе (син) = 0 тоді

ідеї = МетаданниеКонстанта (ін) Ідентифікатор значен = КонстантаПолучітьАтрібут (іден) Повідомити (іден + ” + сін + ” + значен)

КонецЕсли конецЦікла / / Для • КонецПроцедури / / Виконати

Зауваження  Вбудована функція ПустоеЗначеніе (параметр) поверне нуль, якщопараметр визначений (має значення), і одиницю в іншому випадку

Ця програма приклад роботи з метаданими, в якому використаний метод МетаданниеКонстанта, який повертає при роботі з константами такі величини:

• якщо не заданий параметр, число констант в конфігурації

• константу, розташовану в конфігурації під номером ін, якщо параметром методу є целочисленная мінлива ін, наприклад МетаданниеКонстанта (ін)

• константу, що має ідентифікатор ідеї, якщо параметром методу є символьна змінна ідеї, що містить значення ідентифікатора, наприклад:

перем ідеї, конст ідеї = ГлБухгалтер;

конст = МетаданниеКонстанта (іден)

Повідомити (конст) / / Поверне значення синоніма, наприклад Головний бухгалтер

Викликаючи цей метод, можна отримати такі відомості про константі:

• ідентифікатор, наприклад АдресГНІ

• синонім, наприклад Адреса ДПІ

• коментар, наприклад Адреса ДПІ

• тип, наприклад Рядок

• вид, наприклад ДаНет, якщо тип константи Перерахування

• довжина, наприклад 240

• точність, наприклад 0

• ненегативний, наприклад 0

• разделятьТріади, наприклад 0

• періодичний, наприклад 0

• областьРаспространенія, наприклад ВсеІнформаціонниеБази

ПрикладПроцедура

Повідомити (МетаданниеКонстанта (1) Довжина) / / Поверне, наприклад, 240 виведе у вікні повідомлень дані про довжину першої константи

Джерело: Бартеньев О В 1С: Підприємство: програмування для всіх Базові обєкти та розрахунки на одній дискеті М: Діалог-МІФІ, 2005 464 с

Схожі статті:


Сподобалася стаття? Ви можете залишити відгук або підписатися на RSS , щоб автоматично отримувати інформацію про нові статтях.

Коментарів поки що немає.

Ваш отзыв

Поділ на параграфи відбувається автоматично, адреса електронної пошти ніколи не буде опублікований, допустимий HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*