ЗМІНА СТРУКТУРИ І ФОРМ ДОВІДНИКА – ЧАСТИНА 1

Приспособим довідник Сотруднікі_2 для зберігання інформації про освіту співробітника Для цього буде потрібно провести деяку додаткову роботу створити довідник Образованіе_2 Вона необхідна, оскільки вбудований довідник Освіта має власника довідник Співробітники

Структуру довідника Образованіе_2 зробимо максимально простий, використавши в ньому тільки встановлені за замовчуванням реквізити Код і Найменування Далі внесемо в поле Найменування наведені на рис 528 записи

Рис 528 Склад довідника Образованіе_2

Значення цих записів будемо використовувати для визначення (ще неіснуючого) реквізиту Образованіе_2 довідника Сотруднікі_2

При створенні довідника Образованіе_2 додамо команду його виклику в колонку Довідники меню інтерфейсу Учень

Перемістимося знову в конфігурацію і поповнимо довідник Сотруднікі_2 реквізитом Образованіе_2, зробивши його неперіодичним, встановивши для нього тип Довідники з різновидом типу Образованіе_2 і задавши властивість Сортування (рис 529)

Рис 529 Властивості реквізиту Освіта: а загальні б додаткові

Змінимо відповідним чином і форми елемента і списку довідника (основну і для вибору), відкривши їх в конфігураторі, вибравши на панелі інструментів

Елементи діалогу іконку і додавши в них реквізит Освіта (рис 530)

Рис 530 Форма елемента з доданим полем Освіта

Збережемо конфігурацію, скористаємося новою формою і відредагуємо всі елементи довідника Сотруднікі_2, визначивши для них значення реквізиту Освіта Для полегшення роботи можна задати однакове значення цього реквізиту всім співробітникам, використавши наступний код:

/ / Всі співробітники після виконання цієї процедури в поле Освіта

/ / Будуть мати значення Вища

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем сСотр_2, сОбр_2

ОчістітьОкноСообщеній ()

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2) сОбр_2 = СоздатьОбект (СправочнікОбразованіе_2) якщо сОбр_2НайтіПоНаіменованію (Вище) = 0 тогда

Попередження (3наченіе не знайдено”) повернення

КонецЕсли сСотр_2ВибратьЕлементи ()

поки сСотр_2ПолучітьЕлемент ()> 0 цикл

якщо сСотр_2ЕтоГруппа () = 0 тоді

/ / Використовуємо в правій частині присвоювання метод ТекущійЕлемент сСотр_20бразованіе = сОбр_2ТекущійЕлемент () сСотр_23апісать () / / Фіксуємо зміни

КонецЕсли конецЦікла

/ / Перегляд результату ОткрытьФорму(&quotСправочникСотрудники_2ФормаСписка&quot)

КонецПроцедури / / Виконати

Виконаємо тепер ручне редагування значення реквізиту Освіта і зобразимо змінений довідник на рис 531

Рис 531 Поповнений довідник Сотруднікі_2

Виберемо тепер дані з реквізиту Освіта

процедура Виконати () / / Вибирає дані з реквізиту Освіта перем сСотр_2, сОбр_2

перем обр, прапор ОчістітьОкноСообщеній ()

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2) сОбр_2 = СоздатьОбект (СправочнікОбразованіе_2) якщо сОбр_2НайтіПоНаіменованію (Вище) = 0 тогда

Попередження (3наченіе не знайдено”) повернення

КонецЕсли

обр = сОбр_2ТекущійЕлемент ()

/ / Вибираємо співробітників, що мають вищу освіту, по порядку (без урахування ієрархії) прапор = сСотр_2ВыбратьЭлементыПоРеквизиту(&quotОбразование&quot, обр, 0, 0)

якщо прапор = 0 тоді

Попередження (Ні обраних співробітників”) повернення

КонецЕсли

поки сСотр_2ПолучітьЕлемент ()> 0 цикл Повідомити (сСотр_2Наіменованіе + сімволТабуляціі + сСотр_2Код +

сімволТабуляціі + сСотр_2Родітель +

сімволТабуляціі + сСотр_2Образованіе) конецЦікла КонецПроцедури / / Виконати

Результат:

Абрамова Лариса Сергіївна

201

02 Цех

Вища

Агальцов Юрій Олексійович

111

01/1

Вища

Безверхний Ігор Петрович

301

03 Цех

Вища

Кузьміна Раїса Миколаївна

122

01/2

Вища

Смирнова Ніна Федорівна

132

01/3

Вища

Якщо перед викликом методу ВыбратьЭлементыПоРеквизиту звернутися до методу ОбратнийПорядок з рівним одиниці параметром:

сСотр_20братнийПорядок (1)

то результуюча вибірка буде впорядкована у зворотному порядку:

Смирнова Ніна Федорівна

132

01/3

Вища

Кузьміна Раїса Миколаївна

122

01/2

Вища

Безверхний Ігор Петрович

301

03 Цех

Вища

Агальцов Юрій Олексійович

111

01/1

Вища

Абрамова Лариса Сергіївна

201

02 Цех

Вища

Зауваження   Спроба застосувати з методом ВыбратьЭлементыПоРеквизиту метод ПорядокКодов, що передбачає виведення даних по зростанню значень атрибута Код, успіхом не увінчалася

56&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp Управлінням Е записів і ДОВІДНИК А ПР І ПОМОЩ і документів В

561 ПРИЗНАЧЕННЯ ДОКУМЕНТІВ

Процеси, що протікають на підприємстві, регулюються документами Так, прийом на роботу здійснюється на підставі відповідного наказу Надходження ма теріалів на склад фіксується прибутковими ордерами, а їх відпуск у виробництві виконується на підставі вимог-накладних і т д

Не менше, ніж на реальному підприємстві, значення надається документам і в 1С Фактично вони лежать в основі реалізованих в 1С моделей моделі складу, бухгалтерського обліку та ін

Кадровий облік і нарахування заробітної плати також грунтуються на документах: на наказах про прийом на роботу, переміщенні по службових сходах, про зміни окладу, про преміювання та ін Звідси випливає, що більшість змін довідника Сотруднікі_2, що зберігає кадрові дані, повинно здійснюватися на підставі відповідних документів

Створимо і ми документи, що додають дані в довідник Сотруднікі_2 і змінюють в ньому дані про окладах працівників підприємства Зрозуміло, такими документами можуть бути Наказ про прийомі на роботу та Наказ про зміну окладу Документи, які потрапили в зону нашої уваги, враховуючи скромний обсяг зберігається в довіднику Сотруднікі_2 інформації, вельми прості, що цілком відповідає навчальним цілям

Документ 1С складається з форми і модуля документа Форма документа, як і форми інших обєктів 1С, має діалог, модуль і таблиці Діалог форми документа у загальному випадку містить шапку і табличну частину У модулі документа в загальному випадку створюються процедури ОбработкаПроведенія і ОбработкаУдаленияПроведения, що виконують передбачені при проведенні і видаленні документа дії (Проведення документаце процес, що призводить до зміни повязаних з документів обєктів) Так, проведення Наказу про прийом повинно призводити до появи в довіднику Сотруднікі_2 нового запису, а проведення Наказу про зміну окладу до зміни значень періодичного реквізиту Оклад довідника Випущені документи зберігатимемо в наявному в конфігурації Заробітна плата і кадри журналі ПріказиКадровие

Оскільки Наказ про прийом на роботу стосується однієї людини, то в діалозі його форми таблична частина буде відсутня Наказ про зміну окладів може поширюватися на кілька співробітників, ПІБ та нові оклади яких фіксуються в табличній частині діалогу форми документа

Щоб встановити звязок між створюваними документами і записами довідника Сотруднікі_2, додамо в довідник ще два реквізити ПріказПріем і ПріказОклад, присвоївши їм тип Документ Тепер довідник Сотруднікі_2 має наведені на рис 532 реквізити, а також реквізити Код і Найменування

Рис 532 Реквізити довідника Сотруднікі_2

Такий звязок дозволить нам звертатися до створених документам з форми списку довідника

562 НАКАЗ ПРО ПРИЙОМ НА РОБОТУ

5821 РЕКВІЗИТИ І ФОРМА ДОКУМЕНТА

Почнемо з Наказу про прийом Відкриємо конфігурацію, виділимо розділ Документи, натиснемо на праву кнопку миші і виберемо пункт Новий документ

Визначимо реквізити шапки документа відповідно до табл 53

Реквізити шапки Наказу про прийом на роботу

Таблиця 53

Реквізит

Тип (різновид типу)

ДлінаТочность

Код

Числовий

50

ПІБ

Символьний

30

Підрозділ

СправочнікСотруднікі_2

Освіта

СправочнікОбразованіе_2

Оклад

Числовий

102

ДатаПріема

Дата

Співробітник

СправочнікСотруднікі_2

Зауваження:

1 Тип (різновид типу) і характеристики типу (довжина, точність) повинні відповідати аналогічним реквізитами довідника Сотруднікі_2

2 Код співробітника формується автоматично при додаванні нового запису Редагуванню значення коду не підлягає, тому в діалозі форми документа поле Код доступно тільки для читання

3 Реквізит Співробітник введений в документ для встановлення звязку документа з конкретною записом довідника Сотруднікі_2 Для позиціонування довідника в режимі редагування документа можна використовувати виклик

Джерело: Бартеньев О В 1С: Підприємство: програмування для всіх Базові обєкти та розрахунки на одній дискеті М: Діалог-МІФІ, 2005 464 с

Схожі статті:


Сподобалася стаття? Ви можете залишити відгук або підписатися на RSS , щоб автоматично отримувати інформацію про нові статтях.

Коментарів поки що немає.

Ваш отзыв

Поділ на параграфи відбувається автоматично, адреса електронної пошти ніколи не буде опублікований, допустимий HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*