ПОЗИЦІЯ ДОВІДНИКА. ВИБІР ДАНИХ

Довідник, якщо число його записів більше нуля, може бути позиціонується або перед своєю першою записом, або на записи, або слідом за останнім записом

Відразу після створення довідника його позиція не визначена Позицію довідника змінюють методи пошуку даних, наприклад НайтіЕлемент або НайтіПоКоду Значення елемента в поточній позиції повертає функція ТекущійЕлемент

У процесі роботи можна вибрати всі або частину елементів довідника, відкривши вибірку методом ВибратьЕлементи або ВыбратьЭлементыПоРеквизиту В результаті їх застосування довідник позиціонується на своєму першому записі Переміщення по записах здійснюється методом ПолучітьЕлемент

Приклад 1Виводиться список цехів підприємства

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем сСотр_2

ОчістітьОкноСообщеній ()

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2) сСотр_2ВибратьЕлементи ()

поки сСотр_2ПолучітьЕлемент () = 1 цикл

якщо (сСотр_2ЕтоГруппа () = 1) і (сСотр_2Уровень () = 1) тоді Повідомити (сСотр_2 Найменування)

КонецЕсли

конецЦікла КонецПроцедури / / Виконати

Результат:

01 Цех 02 Цех 03 Цех

Приклад 2Виводиться список підрозділів першого цеху підприємства

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем сСотр_2

ОчістітьОкноСообщеній ()

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2)

/ / Якщо не знайдений перший цех (його код дорівнює одиниці) якщо сСотр_2НайтіПоКоду (1, 0) = 0 тоді

Попередження (Перший цех не найден”) повернення

КонецЕсли

/ / Обмежуємо вибірку першого цехом сСотр_2ИспользоватьРодителя (сСотр_2) сСотр_2ВибратьЕлементи ()

поки сСотр_2ПолучітьЕлемент () = 1 цикл якщо сСотр_2ЕтоГруппа () = 1 тоді

Повідомити (сСотр_2Наіменованіе)

КонецЕсли конецЦікла

КонецПроцедури / / Виконати

Результат:

01 / 1

02/2

03/3

Вибір з реквізиту методом ВыбратьЭлементыПоРеквизиту можливий тільки для непериодического_реквизита, якщо для нього на закладці Додаткові встановлено, властивість Сортування (За замовчуванням властивість Сортування має реквізити Код і Найменування)

З перерахованими в цьому розділі методами при виборі даних використовуються методи ОбратнийПорядок, ПорядокНаіменованій, ПорядокКодов, ВключатьПодчіненние, ІспользоватьРодітеля, ІспользоватьВладельца і ІспользоватьДату

Джерело: Бартеньев О В 1С: Підприємство: програмування для всіх Базові обєкти та розрахунки на одній дискеті М: Діалог-МІФІ, 2005 464 с

Схожі статті:


Сподобалася стаття? Ви можете залишити відгук або підписатися на RSS , щоб автоматично отримувати інформацію про нові статтях.

Коментарів поки що немає.

Ваш отзыв

Поділ на параграфи відбувається автоматично, адреса електронної пошти ніколи не буде опублікований, допустимий HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*