ЗАГАЛЬНІ МЕТОДИ ДОВІДНИКІВ

Наведемо їх в табл 58 Після таблиці розташуємо приклади, ці методи ілюструють Нагадаємо, що методи-функції можуть бути викликані і як процедури, тобто у вигляді окремих операторів

-У про

Встановлює для довідника спр, вигляд якого не визначений, види для вибору методом Вибрати й повертає рядок, що містить раніше встановлені види для вибору Може бути також вжито і для реквізиту типу Довідник невизначеного вигляду, що є компонентом іншого обєкта

Нові види для вибору задаються у вигляді рядка, що містить розділені комами ідентифікатори довідників, наприклад

відиНое = Сотруднікі_2, Образованіе_2;

ЯкщовідиНое містить більше одного ідентифікатора, то метод Вибрати активізує діалог, що пропонує

Метод

Опис

вибрати один з довідників (рис 559)

ЯкщовідиНов =” або метод ВідиДляВибора

НЕ вжиті зовсім, то метод Вибрати викличе діалог, подібний зображеному на рис 560, з повним списком довідників конфігурації

вибТек =спрВиборГруппи

([ВибНов])

Встановлює режим вибору груп для методу Вибрати й для елементів діалогу типу Довідник Групи можна вибирати в діалозі, якщо вибНов = 1, і не можна інакше За замовчуванням вибір груп дозволений для елемента діалогу типу Довідник в формі обробки (звіту) і заборонений, якщо діалог вибору активізується методом Вибрати й якщо елемент діалогу типу Довідник розміщений у формах документів, журналів чи довідників Метод повертає існував до його виклику режим вибору груп Якщо параметр вибНов опущений, то режим вибору груп не змінюється

елем = спрТекущійЕлемент ()

Повертає значення поточного елемента довідника

Возвращаемая величина має тип Довідник з різновидом, що повертається методом Вид

полнКод = СпрПолнийКод ()

Повертає рядок, що містить повний код поточного елемента довідника

полнІмя = СпрПолноеНаіменованіе ()

Повертає рядок, що містить повне найменування поточного елемента довідника

* Прапор = СпрНайтіЕлемент (спрЕлем)

Шукає елемент спрЕлем довідника і позиціонує довідник на елементі і повертає 1, якщо пошук вдалий, або не змінює позицію довідника і повертає 0 в іншому випадку Елемент спрЕлем повинен мати тип Довідник

* Прапор = спрНайтіПоКоду (код),

[Режим])

Поверне 1 і перемістить позицію довідника

на елемент з кодом (або повним кодом) код, якщо такий елемент знайдено в іншому випадку поверне 0, позиція довідника збережеться

Пошук виконується, якщо режим дорівнює:

• 0, у всьому довіднику

• 1, в межах батька, заданого методом ІспользоватьРодітеля, або серед елементів рівня 1, якщо батько явно не заданий

• 2, по повному коду

Повний код це рядок, в якій коди рівнів розділені символом /, наприклад 1/12/121; повертається методом ПолнийКод

Значення параметра режим за замовчуванням є:

• 0, для довідника, код в якому унікальний у межах всього довідника

• 2, для довідника, код в якому унікальний у межах групи

ротівн

Метод

Опис

* ПорТек = СпрОбратнийПорядок

([Порно])

Якщо параметр Порно =1, то вибірка елементів, що відкривається методами ВибратьЕлементи або ВыбратьЭлементыПоРеквизиту і здійснювана методом За лучітьЕлемент, виконується у зворотному порядку,

і та ж вибірка виконується в прямому порядку, ес

Чи Порно = 0 Повертає порядок вибірки, що існував до виклику методу За замовчуванням заданий прямий порядок вибірки Якщо параметрпорно опущений, то метод тільки поверне поточний порядок вибірки, що не провівши ніяких змін Приклад див розд 57

* Прапор = СпрПолучітьЕлемент

([Режим])

Повертає 1, якщо вдалося вибрати елемент вибірки, відкритої методом ВибратьЕлементи, або 0 –

в іншому випадку (у вибірці немає елементів або

вибірка вичерпана) Після успішного вибору метод ПолучітьЕлемент переміщує довідник на наступну позицію вибірки або за її межі, якщо всі елементи вибрані Обраний елемент повертається методом ТекущійЕлемент Вибір

черговий позиції здійснюється з урахуванням порядку, встановленого методами:

• ВключатьПодчіненние

• ІспользоватьВладельца

• ІспользоватьДату

• ІспользоватьРодітеля

• ОбратнийПорядок

• ПорядокКодов

• ПорядокНаіменованій

• ПорядокРеквізіта

** ДатаТек =спрІспользоватьДату ([датаНов], [відразу])

Встановлює параметром датаНов,мають тип Дата, дату вибірки або запису періодичних реквізитів довідника або обєкта типу Довідник, що є компонентом іншого обєкта, наприклад Документа Повертає раніше встановлену для періодичних реквізитів дату Якщо параметр відразу = 1, то задана методом дата використовується в поточній вибірці, якщо відразу = 0, то –

в наступної За замовчуванням відразу = 0 Не може бути

використаний разом з методами Отримати та Встановити • Не може мати подвійного префікса (див приклад для методу), наприклад такого: докСотрудникИспользоватьДату (ТекущаяДата ()). Якщо параметр датаНовопущений, то метод тільки поверне раніше встановлену для періодичних реквізитів дату

Метод

Опис

** ВладТек = спрІспользоватьВладельца ([власник],  [флагІзм])

Задає параметромвласник, мають тип Довідник з різновидом довідника-власника, елемент-власник Після завдання власника методи ВибратьЕлементи (ВыбратьЭлементыПоРеквизиту) і ПолучітьЕлемент, викликані для підлеглого довідника, зможуть вибрати лише елементи, підлеглі елементу-власнику Також задає елементвладелец для елемента, який додається в підлеглий довідник

Якщо флагІзм= 1, то елемент-власник може бути змінений інтерактивно або при виборі значення елемента діалогу типу Довідник, або при виклику методу Вибрати Елемент-власник не може бути змінений при інтерактивному виборі елементів, якщо флагІзм = 0 Типово флагІзм = 1

Метод повертає раніше встановлений елемент-

власник Причому якщо параметрвласник опущений, то метод тільки поверне існуючого власника, не проводячи інших дій Приклад вживання методу дан в розд 5103 і 5105

** РодТек = спрІспользоватьРодітеля ([батько], [флагІзм])

Задає групу довідника, в якій методами довідника буде здійснюватися вибір, пошук або додавання даних Також вживається для завдання батька з елементами діалогу типу Довідник Група задається параметром батько,мають

тип Довідник і містить значення групи спра

вочніка

Параметр флагІзммає той же зміст, що

і однойменний параметр методу ІспользоватьВладельца

Метод повертає раніше встановленого батька Причому, якщо параметр батько опущений, то метод тільки поверне існуючого батька

* ВклТек = спрВключатьПодчіненние ([включати])

Якщо параметр включати = 1, то у вибірку включаються підлеглі елементи, якщо включати= 0, то у вибірку потраплять тільки імена груп першого рівня

За замовчуванням підлеглі елементи включаються

у вибірку

Повертає поточне значення режиму включення підлеглих Якщо параметр включати опущений,

то єдине призначення методу це повернути існуюче значення режиму включення підлеглих

* СпрПорядокКодов ()

Якщо метод викликаний, то вибірка методом Отримати Елемент здійснюватиметься в порядку зростання їх кодівЗауваженняЗа замовчуванням вибірка виконується в порядку зростання основного подання довідника (рис 55), тобто Назви або Кода

Метод

Опис

* СпрПорядокНаіменованій ()

Якщо метод викликаний, то вибірка методом Отримати Елемент здійснюватиметься в порядку зростання їх найменувань (див також зауваження до методу ПорядокКодов)

* СпрПорядокРеквізіта (Реквієм)

Якщо метод викликаний, то вибірка методом Отримати Елемент буде здійснюватися в порядку зростання значення реквізиту реквієм Метод може бути застосований лише з реквізитом, для якого задано властивість Сортування (див рис 529, б) Якщо ця умова не виконана або реквізит заданий невірно, то виникне завершальна помилка виконання

* СпрНовий ()

Створює порожню запис Для її додавання в довідник визначаються відповідні реквізити і викликається метод Записати Приклад див розд 5531

* СпрНоваяГруппа ()

Створює порожню запис нової групи Для її додавання в довідник визначаються реквізити групи, наприклад Код і Найменування, і викликається метод Записати Приклад див розд 5531

префТек = спрПрефіксКода

([ПрефНов])

Встановлює префікс, що вживається при автоматичному обчисленні значення атрибута Код Параметр префНов,містить значення префікса, має символьний тип Повертає префікс, заданий попереднім викликом методу Якщо код має числовий тип, то префікс ігнорується

спрУстановітьНовийКод (преф)

Додає до коду елемента довідника префікс, заданий параметромпреф

спрНазначітьТіп

(Реквієм, тип, [довжина], [точність])

Призначає тип або різновид типу, задану параметромтип, реквізиту реквієм невизначеного типу Символьний параметр тип може приймати значення базового типу (Число, Рядок, Дата), будь визначеної в конфігурації різновиди типу, наприклад СправочнікДеті або ДокументІзмененіеОклада, або значення виду субконто

спр3апісать ()

Оновлює поточний елемент довідника Метод, на відміну від команди діалогу # 3апісать, не викликає зумовлену процедуру ПріЗапісі

* СпрУдаліть (спосіб)

Якщоспосіб = 1, то проставляє DBF-позначку видалення поточного запису Такий запис засобами 1С воестановіть не можна Якщоспосіб = 0, то проставляє 1Спометку видалення поточного запису (див розд 552)

За замовчуванням спосіб = 1 Якщо видаляється запис

довідника-власника, то будуть видалені (помічені для видалення) та всі підлеглі їй записи

прапор = СпрПометкаУдаленія ()

Повертає 1, якщо поточна запис має 1 С-позначку видалення, або 0-в іншому випадку

Метод

Опис

* СпрСнятьПометкуУдаленія ()

Знімає 1С-позначку видалення поточного елемента довідника Якщо запис, з якою знімається 1Спометка видалення, має підлеглі записи в іншому довіднику і вони також мають 1С-позначку видалення, то 1С-позначка видалення буде знята тільки

із запису-власника

прапор = спрБлокіровка ([БЛК])

Повертає / встановлює режим блокування запису

Якщо БЛК = 1, то блокування встановлюється,

і блокування відключається, якщо БЛК = 0 Повертає 1 якщо є блокування, або 0-в іншому випадку

Зауваження:

1 Імяспр змінної типу Довідник, вжите в табл 58 перед названі «мі методів, може бути довільним

2 У формі елемента, групи або списку довідника методи, якщо вони застосовуються тільки для поточного довідника, викликаються без префікса

3 Методи, відмічені в табл 58 зірочкою, можна використовувати тільки з обєктів тами, створеними функцією СоздатОбект Тобто їх не можна вживати для поточного довідника у формі його елемента, групи або списку

4 Методи, відмічені в табл 58 двома зірочками, можна використовувати як з обєктами, створеними функцією СоздатОбект, так і для реквізитів тип Довідник, які є компонентами інших обєктів, наприклад докумен тов або довідників іншого виду

5 Імя реквізиту Реквієм, використовуване в методах, є символьним виразом повертає рядок з імям реквізиту, наприклад рядок Оклад.

6 У методах УстановітьАтрібут і ПолучітьАтрібут при невірному значенні пар з метра реквієм виникне завершальна помилка, супроводжувана сполученням Неправильне імя атрибута.

7 Параметри методів, якщо це не обмовляється особливо, євхідними

8 При зміні значень реквізитів методами Встановити, УстановітьАтрібута УстановітьНовийКод, Записати зумовлена процедура ПріЗапісі модуля форми елемента (групи) або списку не викликається

ПрикладиРозташуємо їх у процедурі Виконати модуля обробки Проба Сенс фрагментів пояснюється користувачеві у вікні, що викликається вбудованою процедурою Попередження

процедура Виконайте () / / Повязана з кнопкою Пуск обробки Проба перем сСотр_2, сОбр_2, спр, прапор, гр, обр

перем відиТек, відиНов, рід, діти

ОчістітьОкноСообщеній ()

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2)

// Приклад для методу Вид

Попередження (‘ Створюємо довідник невизначеного виду )

// спр обєкт типу Довідник невизначеного виду спр = СоздатьОбект (Довідник)

спрВід (Образованіе_2)

//

Задаємо різновид типу обєкта спр

Повідомити (спрВід ())

//

Надрукує Образованіе_2

// Приклад для методів НайтіПоНаіменованію, НайтіПоКоду,

/ / УстановітьАтрібут, Записати і ПолучітьАтрібут

Попередження (Міняємо реквізит Освіта у співробітника з кодом 302″)

/ / Шукаємо по частині найменування

прапор = спрНайтіПоНаіменованію (Нач, 0) якщо прапор = 1 тоді

/ / Шукаємо у всьому довіднику

прапор = сСотр_2НайтіПоКоду (302, 0)

якщо прапор = 1 тоді / / Сотрудник знайдений сСотр_2УстановітьАтрібут (Освіта, спрТекущійЕлемент ()) сСотр_23апісать ()

/ / Ті ж зміни викличуть два наступних оператора:

/ / ССотр_20бразованіе = спрТекущійЕлемент ()

/ / ССотр_23апісать () Повідомити (сСотр_2ПолучітьАтрібут (Освіта))

/ / То ж повідомлення виведе оператор

/ / Повідомити (сСотр_2Образованіе))

/ / Перегляд результату

сСотр_2Вибрать (Перегляд результату, ФормаСпіска) інакше

Попередження (Співробітник з кодом 302 не найден”) КонецЕсли

інакше

Попередження (В довіднику Образованіе_2 немає

| Елемента з найменуванням Початкове ) КонецЕсли

// Приклад для методів ТекущійЕлемент ЕтоГруппа ПрінадлежітГруппе

/ / ВибратьЕлементи, ПолучітьЕлемент і Вибрано

Попередження (Виводиться список співробітників цеху 1″ + РазделітельСтрок + Імена підрозділів цеху не виводяться”)

прапор = сСотр_2НайтиПоНаименованию (01 Цех)

якщо прапор = 1 тоді

якщо сСотр_2ЕтоГруппа () = 1 тоді

/ / Запамятовуємо знайдену групу гр = сСотр_2ТекущійЕлемент () сСотр_2ВибратьЕлементи ()

поки сСотр_2ПолучітьЕлемент () = 1 цикл

/ / Чи не виводимо імена підрозділів першого цеху

якщо (сСотр_2ПрінадлежітГруппе (гр) = 1) і (сСотр_2ЕтоГруппа () = 0) тоді Повідомити (сСотр_2Наіменованіе)

КонецЕсли

конецЦікла / / Поки

/ / Після такого циклу метод Вибрано поверне 0

якщо сСотр_2Вибран () = 0 тоді

Повідомити (Після циклу Поки елемент довідника не вибрано”) КонецЕсли

інакше

Попередження (Знайдений елемент не група”) КонецЕсли

інакше

Попередження (Імя 01 Цех не знайдено”) КонецЕсли

// Приклад для методів ВідиДляВибора, ВиборГруппи і Вибрано

/ / А також для методів ПолнийКод і ПолноеНаіменованіе спр = 0

// спр довідник невизначеного виду спр = Создать0бект (Довідник) відиНов = Сотруднікі_2, Образованіе_2;

Попередження (Якщо виберете вид Співробітники, то отримаєте повні код

| І найменування обраного слідом елемента довідника ) відиТек = спрВідиДляВибора (відиНов)

/ / Дозволяємо вибір груп у діалозі вибору За замовчуванням вибір груп заборонений спрВиборГруппи (0)

прапор = спрВибрать (, ФормаСпіска) якщо прапор = 1 тоді

якщо спрВід () = Сотруднікі_2 тоді

Повідомити (Вибрано співробітник: + спрНаіменованіе)

/ / Наступний виклик надрукує, наприклад, 1/12/121

Повідомити (спрПолнийКод ())

/ / Надрукували, наприклад, 01 Цех / 01/2 / Волосків Михайло Андрійович Повідомити (спрПолноеНаіменованіе ())

інакше

Повідомити (Вибрані освіта: + спрНаіменованіе) КонецЕсли

інакше

Попередження (Співробітник не вибрано”) КонецЕсли

// Приклад для метопа НайтіЕлемент: довідник Сотруднікі_2

/ / Позиціонується на батьку обраного елемента Попередження (Після вибору співробітника відкриється форма,

| В якій обраний батько співробітника )

сСотр_2ВиборГруппи (0) / / Забороняємо вибір груп

/ / Відкриваємо діалог форми для вибору

прапор = сСотр_2Вибрать (Виберіть співробітника, ФормаСпіска) якщо прапор = 1 тоді

сСотр_2НайтіЕлемент (сСотр_2Родітель)

сСотр_2ВиборГруппи (1) / / Дозволяємо вибір груп сСотр_2Вибрать (Курсор розміщений на батьку раніше обраного елемента,

“ФормаСпіска)

інакше

Попередження (Елемент не вибрано”) КонецЕсли

// Приклад для методів НайтіПоРеквізіту і ІспользоватьРодітеля Попередження (Після вибору виду освіти і підрозділи

| Відкриється форма довідника Сотруднікі_2, в якій

| Обраний співробітник, що має обраний вид освіти )

/ / Попередньо вибираються вид освіти обр і підрозділ (група)

/ / Потім виконується пошук співробітника, що має освіту обр

// і працюючого в обраному підрозділі сСотр_2 = 0

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2) сОбр_2 = СоздатьОбект (СправочнікОбразованіе_2)

/ / Вибираємо вид освіти обр

прапор = сОбр_2Вибрать (Виберіть вид освіти, “) якщо прапор = 1 тоді

обр = сОбр_2ТекущійЕлемент ()

/ / Вибираємо підрозділ подр

// Дозволяємо вибір груп у діалозі вибору За замовчуванням вибір груп заборонений сСотр_2ВиборГруппи (1)

прапор = сСотр_2Вибрать (Виберіть цех, “) якщо сСотр_2ЕтоГруппа () = 1 тоді

/ / Пошук обр в групі сСотр_2

рід = сСотр_2ТекущійЕлемент () сСотр_2ИспользоватьРодителя (рід)

прапор = сСотр_2НайтіПоРеквізіту (Освіта, обр, 0)

якщо прапор = 1 тоді

/ / Покажемо результат у формі списку для вибору сСотр_2Вибрать (Курсор розміщений на знайденому співробітника, “)

інакше

Попередження (В підрозділі + родНаіменованіе + немає співробітника

| З утворенням + ОбрНаіменованіе) КонецЕсли

інакше

Попередження (Цех не вибрано”) КонецЕсли

інакше

Попередження (Вид освіти не вибраний”) КонецЕсли

/ / Приклад для методів ІспользоватьРодітеля і Вибрати

/ / В як батька задається другий цех Потім використовується метод Вибрати

/ / Перший раз батько може бути змінений при інтерактивному виборі, другий раз немає прапор = сСотр_2НайтіПоКоду (2,0) / / 2 код другого цеху

якщо прапор = 1 тоді

Попередження (В першій формі батька міняти можна, а в другій можна) рід = сСотр_2ТекущійЕлемент ()

сСотр_2ИспользоватьРодителя (рід, 1)

/ / Можна вибирати співробітників з будь-якої групи сСотр_2Вибрать (Можна міняти батька, ФормаСпіска)

/ / Працівників можна вибрати тільки з другого цеху

сСотр_2ИспользоватьРодителя (рід, 0)

сСотр_2Вибрать (Батька змінити не вдається, ФормаСпіска) інакше

Попередження (Цех з кодом 2 не найден”) КонецЕсли

// Приклад для методу ІспользоватьДату

/ / Створюється обєкт типу Документ з різновидом ПріказОПріеме,

/ / Що має, як відомо, реквізит Співробітник, що встановлює звязок документа

/ / З породженої ним записом у довіднику Сотруднікі_2 Використовуючи цей реквізит,

/ / Визначимо нинішній оклад співробітника Горюнової У В,

/ / Прийнятої на роботу за наказом № 1

док = СоздатьОбект (ДокументПріказОПріеме) прапор = докНайтіПоНомеру (1, Дата (0))

якщо прапор = 1 тоді

Попередження (В вікні повідомлень виведемо оклади Горюнова Уляни

| За наказом і на робочу дату )

/ / Не можна встановлювати дату періодичного реквізиту наступним чином:

/ / ДокСотрудникИспользоватьДату (ТекущаяДата ())

/ / Це потрібно робити так:

/ / Визначаємо обєкт з різновидом типу СправочнікСотруднікі_2 співр = докСотруднік

/ / Встановлюємо для цього обєкта дату періодичних реквізитів

сотрІспользоватьДату (докДатаПріема)

/ / Оклад на дату зарахування на роботу має дорівнювати докОклад оклСтар = сотрОклад

/ / Міняємо дату читання періодичного реквізиту Оклад сотрІспользоватьДату (ТекущаяДата ())

оклСегодня = сотрОклад

Повідомити (Оклад за наказом: + оклСтар)

//

Оклад за наказом: 2500

Повідомити (Оклад сьогодні: + оклСегодня)

//

Оклад сьогодні: 3200

інакше

Попередження (Наказ № 1 не знайдене”) КонецЕсли

// Приклад для методів Видалити, ПометкаУдаленія і СнятьПометкуУдаленія

/ / Ставиться позначка видалення на запис з кодом 302 Це викликає простановку

/ / Позначок видалення і на записи в довіднику Діти, підлеглі записи-власнику сСотр_2 0

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2)

прапор = сСотр_2НайтіПоКоду (302, 0) якщо прапор = 1 тоді

якщо Питання (Видалити запис з кодом 302″, Так + Ні) = Так тоді

Попередження (Ставимо позначку видалення співробітнику з кодом 302

| В довіднику Сотруднікі_2 і в підлеглому довіднику Діти )

/ / Проставляємо 1С-позначку видалення (Мал 561)

/ / Якщо діти співробітника занесені в довідник Діти, то відповідні

/ / Їм записи також отримають позначку видалення сСотр_2Удаліть (0) Попередження (Перегляд результату”)

сСотр_2Вибрать (Запис про співробітника з кодом 302 позначена для видалення, “)

діти = СоздатьОбект (СправочнікДеті) детиИспользоватьВладельца (сСотр_2)

детіВибрать (Вилучені записи і в підлеглому довіднику, “) діти = 0

КонецЕсли

інакше

Попередження (Співробітник не найден”) КонецЕсли

/ / Знімаємо позначку видалення з поточного запису

/ / Однак проставлена ​​раніше позначка видалення в підлеглому

/ / Довіднику збережеться

якщо сСотр_2ПометкаУдаленія () = 1 тоді

якщо Питання (Зняти позначку видалення”, Так + Ні) = Так тоді Попередження (Позначка видалення знімається тільки + РазделітельСтрок +

“В довіднику Сотруднікі_2″) сСотр_2СнятьПометкуУдаления () Попередження (Перегляд результату”)

сСотр_2Вибрать (З записи про співробітника з кодом 302 знято позначку видалення, “) діти = СоздатьОбект (СправочнікДеті)

детиИспользоватьВладельца (сСотр_2)

детіВибрать (Діти як і раніше мають позначку видалення, “) КонецЕсли

КонецЕсли

// Приклад для методу ВключатьПодчіненние

Попередження (В вікно повідомлень завдяки методу ВключатьПодчіненние виводяться лише імена груп довідника Сотруднікі_2″)

сСотр_2ВключатьПодчиненные (0) сСотр_2ВибратьЕлементи ()

поки сСотр_2ПолучітьЕлемент () = 1 цикл

Повідомити (сСотр_2Наіменованіе) конецЦікла / / Поки

// Результат:

/ / 01 Цех

/ / 02 Цех

/ / 03 Цех

КонецПроцедури / / Виконати

Рис 561 Видалення запису-власника тягне видалення і підлеглих записів Зауваження  Відразу після вибору нового виду довідника в результаті виклику

відиТек = спрВідиДляВибора (відиНов) метод спрВід () поверне пусте значення

Джерело: Бартеньев О В 1С: Підприємство: програмування для всіх Базові обєкти та розрахунки на одній дискеті М: Діалог-МІФІ, 2005 464 с

Схожі статті:


Сподобалася стаття? Ви можете залишити відгук або підписатися на RSS , щоб автоматично отримувати інформацію про нові статтях.

Коментарів поки що немає.

Ваш отзыв

Поділ на параграфи відбувається автоматично, адреса електронної пошти ніколи не буде опублікований, допустимий HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*