ПЕРЕГЛЯД І ВИБІР ЕЛЕМЕНТІВ ДОВІДНИКА

Довідники можна відкрити в діалозі наступними способами:

• звертаючись до меню системи

• застосовуючи метод довідника Вибрати

• викликаючи в модулі довільної форми функції ОткритьФорму або ОткритьФормуМодально

• вживаючи метод ОткритьПодбор, який викликає форму списку, отображающую

заданий довідник

Додатково функція ОткритьФорму і метод ОткритьПодбор дозволяють, використовуючи контекст відкритої форми (підбору), маніпулювати відкритою формою У випадку методу ОткритьПодбор для цих цілей застосовується зумовлена ​​процедура ОбработкаПодбора

Функції ОткритьФорму і ОткритьФормуМодально дозволяють відкрити як форми елемента і групи довідника, так і форми списку Методи Вибрати й ОткритьПолбор використовують тільки форму списку довідника, імя якої передається методами якості другого параметра

Зауваження   Розміри діалогу модально відкритої форми на відміну від форми, відкритої немодального, не можуть бути змінені

Приклад 1Форма списку основна довідника Сотруднікі_2 відкривається методом Вибрати Якщо елемент обраний, у вікні повідомлень друкується ПІБ співробітника

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем сСотр_2

ОчістітьОкноСообщеній ()

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2)

якщо сСотр_Вибрать (Виберіть співробітника, ФормаСпіска) = 1 тоді Повідомити (сСотр_2Наіменованіе)

інакше / / Метод Вибрати повернув 0

Повідомити (Співробітник не вибрано”) КонецЕсли

КонецПроцедури / / Виконати

Форма, що відкривається методом Вибрати, наведена на рис 517 для вибору можна вжити клавішу Enter, подвійний удар миші, а також іконку

Рис 517 Форма, що відкривається методом Вибрати

Зауваження    Область інтерактивного вибору елементів обмежується методом ІспользоватьРодітеля Так, виклики

сСотр_2ИспользоватьРодителя (рід, 0) сСотр_2Вибрать (Батька змінити не можна, ФормаСпіска)

в яких параметр рідметоду ІспользоватьРодітеля має значення групи довідника, відкриють діалог форми списку довідника, в якому можна вибрати елемент тільки з групи, заданої методом ІспользоватьРодітеля Переміститися за межі цієї групи не можна

Приклад 2Вибір співробітників обмежується підрозділом 01/1 цеху 1

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем сСотр_2, прапор, рід

ОчістітьОкноСообщеній ()

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2)

/ / 11 код підрозділу 01/1 першого цеху

прапор = сСотр_2НайтіПоКоду (11,0) / / Пошук в усьому довіднику якщо прапор = 0 тоді

Попередження (Підрозділ з кодом 11 не знайдено”)

повернення КонецЕсли

/ / Обмежуємо вибір співробітників підрозділ 01/1

/ / Буде після виклику методу Вибрати відкритий наведений на рис 517 діалог рід = сСотр_2ТекущійЕлемент ()

сСотр_2ИспользоватьРодителя (рід, 0)

/ / Замість двох останніх операторів можна вжити один:

/ / ССотр_2ИспользоватьРодителя (сСотр_2, 0)

якщо сСотр_2Вибрать (Батька змінити не можна, ФормаСпіска) = 1 тоді Повідомити (сСотр_2Наіменованіе)

інакше / / Метод Вибрати повернув 0

Повідомити (Співробітник не вибрано”) КонецЕсли

КонецПроцедури / / Виконати

Приклад  3  Форма списку основна довідника Співробітники 2 відкривається функцією ОткритьФорму

процедура Виконати ()

//

Повязана з кнопкою Пуск обробки Проба

перем контПодбора

//

Результат роботи процедури см на рис 5

ОчістітьОкноСообщеній ()

ОткрытьФорму(&quotСправочникСотрудники_2ФормаСписка&quot, контПодбора)

/ / За замовчуванням відкривається форма списку основна, тому наступний виклик

/ / Відкриє ту ж форму, що і попередній

/ / ОткритьФорму (СправочнікСотруднікі_2, контПодбора) Повідомити (контПодбораНаіменованіе) / / Надрукував 01 Цех

КонецПроцедури / / Виконати

Приклад 4Форма введення нового співробітника другого цеху в довідник Сотруднікі_2 відкривається функцією ОткритьФорму Слідом відкривається форма введення нової групи першого хутра

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем сСотр_2, конт1, конт2

ОчістітьОкноСообщеній ()

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2)

якщо сСотр_2НайтіПоКоду (2, 0) = 1 тоді / / 2 код другого цеху

// Відкриваємо форму введення нового співробітника другого цеху

/ / Третій параметр функції задає батьківську групу ОткритьФорму (ЕлементСотруднікі_2′, конт1, сСотр_2ТекущійЕлемент (), 0)

Попередження (Цех 2 не найден”) повернення

КонецЕсли

еслісСотр_2НайтіПоКоду (1, 0) = 1 тоді / / 1 код першого цеху

/ / Відкриваємо форму введення нової групи першого цеху ОткритьФорму (ЕлементСотруднікі_2. Конт2, сСотр_2ТекущійЕлемент (), 1) Повідомити (конт2Код) / / Надрукував код нової групи

інакше

Попередження (Цех 1 не знайдене”) повернення

КонецЕсли КонецПроцедури / / Виконати

Зауваження   У прикладі 4 форма групи буде знаходитися поверх форми елемента

Це визначається порядком їх виклику

Приклад 5  Відкривається форма редагування поточного запису довідника (групи або елементах

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем сСотр_2, конт

ОчістітьОкноСообщеній ()

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2)

/ / Шукаємо по коду у всьому довіднику

якщо сСотр_2НайтіПоКоду (201, 0) = 1 тоді

/ / При цьому виклику параметр функції ОткритьФорму має тип Довідник

ОткритьФорму (ССОТР 2ТекущійЕлемент (), конт 0) інакше

Попередження (Елемент не найден”) повернення

КонецЕсли КонецПроцедури / / Виконати

Приклад 6Форма списку довідника Сотруднікі_2 відкривається методом ОткритьПодбор Зумовлена ​​процедура ОбработкаПодбора запускається при виборі (подвійному ударі миші або натисканні на Enter) осередку третього рівня і виводить у вікно повідомлень атрибути відкритої форми

процедура Виконати ()

//

Повязана з кнопкою Пуск обробки Проба

перем контПодбора

//

Результат роботи процедури см на рис 52

ОчістітьОкноСообщеній ()

/ / За замовчуванням відкривається форма списку для вибору ОткритьПодбор (СправочнікСотруднікі_2,, контПодбора)

КонецПроцедури / / Виконати

/ / Запускається при виборі (подвійному ударі миші або натисканні на Enter) осередки третього рівня I

/ / Приймає як параметр контекст довідника процедура ОбработкаПодбора (конт)

Повідомити (контНаіменованіе) Повідомити (контРодітель)

/ / Дата для доступу до періодичного реквізиту Оклад

контІспользоватьДату (РабочаяДата ()) Повідомити (контОклад)

КонецПроцедури / / ОбработкаПодбора

Можливий варіант повідомлень, що надходять з процедури ОбработкаПодбора: Добрецов Борис Юрійович

01/1

2300

551 Управління записами ЗАСОБАМИ ІНТЕРФЕЙСУ Для вирішення означених в заголовку розділу завдань можна використовувати можливості, що надаються формою списку довідника, що зявляється, наприклад,

після виклику функції ОткритьФорму При цьому можна користуватися іконками інстр

рументальной панелі інструментів (рис 518), пунктами меню колонки Дії або меню, що зявляється при натисканні на праву кнопку миші, встановленої на записи довідника  

Рис 518 Панель інструментів форми списку довідника

Зауваження   Положення панелі інструментів форми списку змінюється в резуль таті виконання ланцюжка Сервіс Панелі інструментів Додаткові Інструментальні панелі вікон (рис 519)

Рис 519 Завдання положення панелі інструментів форми списку довідника

Джерело: Бартеньев О В 1С: Підприємство: програмування для всіх Базові обєкти та розрахунки на одній дискеті М: Діалог-МІФІ, 2005 464 с

Схожі статті:


Сподобалася стаття? Ви можете залишити відгук або підписатися на RSS , щоб автоматично отримувати інформацію про нові статтях.

Коментарів поки що немає.

Ваш отзыв

Поділ на параграфи відбувається автоматично, адреса електронної пошти ніколи не буде опублікований, допустимий HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*