МОДУЛЬ формі елемента довідника ДІТИ

Містить функцію НайтіВозраст і зумовлені процедури прочинені і ПріЗапісі Перша встановлює значення елемента діалогу дт, другий контролює задані в діалозі значення

процедура відкриття () дт = ТекущаяДата ()

КонецПроцедури / / прочинене

/ / Повертає вік дитини

/ / Результат має вигляд, наприклад, 4 роки або 5 років, якщо вік більше одного року,

/ / Або, наприклад, 8 місяців в іншому випадку

функція НайтіВозраст ()

перем НГР, НГТ, НМР, НМТ, чіслоЛет, чіслоМес, зрост якщо ПустоеЗначеніе (ДатаРожденія) = 1 тоді

Попередження (Введіть дату народження”)

повернення “; КонецЕсли

НГР = ДатаГод (ДатаРожденія) / / Повертає рік народження НГТ = ДатаГод (ДТ)

чіслоЛет = НГТ НГР

якщо чіслоЛет> 18 тоді

Попередження (Вік дитини не повинен бути більше 18 років”) повернення “;

КонецЕсли

якщо чіслоЛет < 0 тоді Попередження ("Невірна дата народження."); повернення "";

КонецЕсли

якщо чіслоЛет = 0 тоді

НМР = ДатаМесяц (ДатаРожденія) НМТ = ДатаМесяц (ДТ)

чіслоМес = НМТ НМР

якщо чіслоМес < 0 тоді Попередження ("Невірна дата народження."); повернення "";

КонецЕсли

якщо чіслоМес = 1 тоді зрост = 1 місяць

іначеЕслі (чіслоМес = 2) або (чіслоМес = 3) або (чіслоМес = 4) тоді

/ / Наприклад, 3 місяці

возр = рядок (чіслоМес) + місяця ;

інакше / /чіслоМес > 4 або чіслоМес = Про

/ / Наприклад, 7 місяців

возр = рядок (чіслоМес) + місяців ; КонецЕсли

інакше / /чіслоЛет> 1 якщо чіслоЛет = 1 тоді

возр = 1 рік

іначеЕслі (чіслоЛет = 2) або (чіслоЛет = 3) або (чіслоЛет = 4) тоді

/ / Наприклад, 3 роки

возр = рядок (чіслоЛет) + року ;

інакше / /чіслоЛет> 4

/ / Наприклад, 7 років

возр = рядок (чіслоЛет) + років ; КонецЕсли

КонецЕсли

Вік = зрост повернення зрост

КонецФункции / / НайтіВозраст

процедура ПріЗапісі () / / Зумовлена ​​процедура якщо ПустоеЗначеніе (Вік) = 1 тоді

Попередження (Не визначено вік”)

СтатусВозврата (0) / / Забороняємо запис даних повернення

КонецЕсли

якщо ПустоеЗначеніе (Імя) = 1 тоді Попередження (Введіть імя”)

СтатусВозврата (0) / / Забороняємо запис даних формаАктівізіровать (Імя) / / Встановлюємо курсор на поле Імя повернення

КонецЕсли

якщо (ПустоеЗначеніе (Імя) = 1) або (ПустоеЗначеніе (ДатаРожденія) = 1) тоді

Попередження (Введіть дату народження”)

/ / Встановлюємо курсор на поле ДатаРожденія формаАктівізіровать (ДатаРожденія)

СтатусВозврата (0) / / Забороняємо запис даних КонецЕсли

КонецПроцедури / / ПріЗапісі

Джерело: Бартеньев О В 1С: Підприємство: програмування для всіх Базові обєкти та розрахунки на одній дискеті М: Діалог-МІФІ, 2005 464 с

Схожі статті:


Сподобалася стаття? Ви можете залишити відгук або підписатися на RSS , щоб автоматично отримувати інформацію про нові статтях.

Коментарів поки що немає.

Ваш отзыв

Поділ на параграфи відбувається автоматично, адреса електронної пошти ніколи не буде опублікований, допустимий HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*