АТРИБУТИ ВИДІВ РОЗРАХУНКІВ І ЇХ ГРУП

Приводяться в табл 718

Атрибути ВР та їх груп

Таблиця 718

Атрибут

Опис

Атрибути ВР і груп ВР

Код

Рядок, що містить ідентифікатор ВР або групи ВР

Найменування

Рядок, що містить коментар ВР або групи ВР

Атрибути ВР

Черговість

Число, що задає черговість (пріоритет) виконання ВР (див розд 734)

Пріоритет Витіснення

Число, що задає пріоритет витіснення ВР Не рекомендований для вживання і збережений для підтримки сумісності з колишніми версіями 1С

7152 МЕТОДИ ВИДІВ РОЗРАХУНКІВ І ЇХ ГРУП

Приводяться в табл 719

Методи ВР і груп ВР

Таблиця 719

Метод

Опис

Методи ВР

ВР = ВідРасчета

ПолучітьАтрібут

(Код)

Повертає обєкт типу ВідРасчета, ідентифікатор якого дорівнює символьному параметру код

прапор = <ВР> Входить

ВГругппу (група)

Повертає 1, якщо вид розрахунку ВР входить до групи ВР, задану параметром група типу ГруппаРасчетов

прапор = <ВР.> Вибрано ()

Повертає 1, якщо ВР обєкт типу ВідРасчета має значення, чи О-в іншому випадку Вживається,

зокрема, для реквізитів типу ВідРасчета обєктів 1С, наприклад довідників або документів, з метою дізнатися, чи не встановлено для реквізиту ВР або реквізит має пусте значення

прапор = ВР1Витесняет ВідРасчета (ВР2)

Повертає 1, якщо вид розрахунку ВР1 витісняє вид розрахунку ВР2, або О-в іншому випадку

прапор = ВР1Витесняется ВідомРасчета (ВР2)

Повертає 1, якщо вид розрахунку ВР1 витісняється видом розрахунку ВР2, або О-в іншому випадку

Методи груп ВР

прапор = ГВРСодержіт ВідРасчета (ВР)

Поверне 1, якщо група видів розрахунків ГВР містить вид розрахунку ВР, або О-в іншому випадку

кіл = ГВРКолічество ()

Повертає число ВР, входять до групи розрахунків ГВР

ВР = ГВРПолучіть Розрахунок (ном)

Поверне обєкт типу ВідРасчета, що входить до групи розрахунків ГВР під номером ном Якщо номер ном більше числа розрахунків в групі, то виникне завершальна помилка, супроводжувана сполученням Вихід за межі групи розрахунків

Приклади для методів ВР:

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ВР1, ВР2

перем ін, код, наим, синонім

ОчістітьОкноСообщеній () / / Очищаємо вікно повідомлень ВР1 = ВідРасчетаПреміяСум_2

ВР2 = ВідРасчетаПреміяКоеф_2

якщо ВР1ВитесняетВідРасчета (ВР2) = 1 тоді

Повідомити (ВР Премія сумою витісняє ВР Премія коефіцієнтом”) КонецЕсли

/ / Визначимо змінні ВР типу ВідРасчета іншим способом ВР1 = ВидРасчетаПолучитьАтрибут (ПреміяСум_2)

ВР2 = ВидРасчетаПолучитьАтрибут (ПреміяКоеф_2) якщо ВР1ВытесняетсяВидомРасчета (ВР2) = 1 тоді

Повідомити (ВР Премія сумою витісняється ВР Премія коефіцієнтом”) інакше

Повідомити (ВР Премія коефіцієнтом витісняється ВР Премія сумою”) КонецЕсли

КонецПроцедури / / Виконати

Результат:

ВР Премія сумою витісняє ВР Премія коефіцієнтом

ВР Премія коефіцієнтом витісняється ВР Премія сумою

Прикладидля методів груп ВР:

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ВР, ГВР, кол, ном

ОчістітьОкноСообщеній () / / Очищаємо вікно повідомлень ВР = ВідРасчетаПреміяСум_2

ГВР = ГруппаРасчетовВсеНачисления_2 якщо ГВРСодержітВідРасчета (ВР) = 1 тоді

Повідомити (Трупа ВР + ГВРКод + містить ВР + ВРКод) інакше

Повідомити (Група ВР + ГВРКод + не містить ВР + ВРКод) КонецЕсли

кіл = ГВРКолічество ()

Повідомити (В групу ВР + ГВРКод + входить + к + ВР) ном = 2

ВР = ГВРПолучітьРасчет (ном)

Повідомити (В групі ВР + ГВРКод + під номером + ном + розташований розрахунок + ВРКод)

КонецПроцедури / / Виконати

Результат:

Група ВР ВсеНачісленія_2 містить ВР ПреміяСум_2

У групу ВР ВсеНачісленія_2 входить 4 ВР

У групі ВР ВсеНачісленія_2 під номером 2 розташований розрахунок ПреміяКоеф_2

Джерело: Бартеньев О В 1С: Підприємство: програмування для всіх Базові обєкти та розрахунки на одній дискеті М: Діалог-МІФІ, 2005 464 с

Схожі статті:


Сподобалася стаття? Ви можете залишити відгук або підписатися на RSS , щоб автоматично отримувати інформацію про нові статтях.

Коментарів поки що немає.

Ваш отзыв

Поділ на параграфи відбувається автоматично, адреса електронної пошти ніколи не буде опублікований, допустимий HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*