МЕТОДИ ЖУРНАЛУ РОЗРАХУНКІВ ТА ЙОГО ПЕРІОДУ

Приводяться в табл 716

Методи ЖР і його періоду

Таблиця 716

Метод

Опис

Метод періоду ЖР

пер = перПрібавітьПеріод

(Кіл)

Додає до періоду пер,де пер = ЖрПеріодДействія | жрПеріодРегістраціі | жрТекущійПеріод () або інше значення типу РасчетнийПеріод, задане параметром кіл число періодів

Методи ЖР

нтп = ЖрНачалоТекущего Періоду ()

Повертає дату початку поточного періоду ЖР

КТП = ЖрКонецТекущего Періоду ()

Повертає дату кінця поточного періоду ЖР

нтп = ЖрНачалоПеріода податі (дата)

Повертає дату початку розрахункового періоду ЖР, якому належить заданадата

КТП = жрКонецПеріода податі (дата)

Повертає дату кінця розрахункового періоду ЖР, якому належить заданадата

пер = ЖрПеріодПоДате (дата)

Повертає розрахунковий період ЖР (обєкт типу Розрахунковий Період), якому належить заданадата

прапор = жрУстановітьТекущій Період(Пер, [спосіб])

Встановлює як поточного період пер,де пер –

значення типу РасчетнийПеріод Якщо спосіб = 1, то

при зміні періоду відпрацьовуються її супроводжують системні дії, тобто зміна періоду здійснюється так само, як і при її інтерактивному виконанні Якщо спосіб = 0, то системні дії не відпрацьовуються,

зокрема не проводиться архівація документів при зміні періоду вперед і не змінюється значення атрибута записів Розрахована при зміні назад

пер = ЖрТекущійПеріод ()

Повертає поточний розрахунковий період значення типу РасчетнийПеріод

прапор = жрПолучітьЗапісь ()

Позиціонує вибірку на її наступному записі і повертає 1 або за межами вибірки і повертає 0, якщо вибірка порожня або вичерпана

прапор = жрВиполнітьРасчет ()

Розраховує поточний запис ЖР, звертаючись до процедури ПровестіРасчет, якій забезпечений ВР цього запису

on = жрОпісательПеріода

(Дата)

Повертає рядок, що описує розрахунковий період, що містить дату, задану параметромдата Формат рядка залежить від тривалості розрахункового періоду Якщо тривалість місяць, то результат має, наприклад, такий вигляд: січня 2002 р

зап = ЖрТекущаяЗапісь ()

Повертає поточну запис ЖР значення типу ЗапісьЖурнал аРасчетов

Метод

Опис

прапор = ЖрНайтіЗапісь (зап)

Здійснює в ЖР пошук запису запМінлива зап

повинна мати тип ЗапісьЖурналаРасчетов

прапор = ЖрФіксіровать Запис ()

Встановлює в атрибут Фіксована поточного запису ЖР значення, рівне одиниці

прапор = жрОсвободітьЗапісь ()

Встановлює в атрибут Фіксована поточного запису ЖР значення, рівне нулю

прапор = жрВвестіПерерасчет ()

Вводить в поточний період запис, який є копією поточного запису одного з минулих періодів, обнуляючи її результат Введена запис називається перерахунком, і її атрибут Перерахунок дорівнює одиниці Результат перерахунку зменшується на значення атрибута Результат первинного запису Перерахунок не можна ввести, якщо первинна запис сама є перерахунком

прапор = жрВвестіПерерасчет наосновании (док)

Метод виконує ті ж дії, що й метод ВвестіПерерасчет, з тією лише різницею, що перерахунок вводиться на підставі документа док

названіеЖР= ЖрВід ()

Повертає заданий в конфігурації ідентифікатор ЖР, наприклад Зарплата_2 Результат має символьний тип

предстЖР = жрПредставленіе Віда ()

Повертає заданий в конфігурації синонім ЖР, а за відсутності синоніма ідентифікатор ЖР Результат має символьний тип

жрНазначітьТіп (Реквієм, тип, довжина, точність)

Призначає тип або різновид типу, задану парамет ромтип,реквізиту реквієм невизначеного типу Символьний параметр тип може приймати значення базового типу (Число, Рядок, Дата), будь визначеної в конфігурації різновиди типу, наприклад СправочнікДеті, або ДокументІзмененіеОклада, або значення виду субконто

жрУстановітьРеквізіт

(Реквієм, знач)

Встановлює значення реквізиту ЖР Для збереження значення після застосування методу викликається один з таких методів: ВвестіРасчет, ВвестіРасчетНаОснованіі, ЗапісатьРасчет або ЗапісатьРасчетНаОснованіі При цьому якщо розрахунок вводиться в документі, то в ньому ці методи записують додаткові реквізити ЖР, а також (у міру необхідності) атрибути Сторно, Розрахована, Виправлена, Фіксована, Перерахунок та Результат значення атрибутів Документ, РодітельскійДокумент, Обєкт, ВідРасч, ДатаНачала, ДатаОкончанія і ПервічнаяЗапісь в цьому випадку методом УстановітьРеквізіт не задаються

Також метод УстановітьРеквізіт вживається з методами Нова і Записати Причому метод Нова передує викликом методу УстановітьРеквізіт Методи можуть застосовуватися як

в документах, так і в модулях інших обєктів При цьому Ус-

тановітьРеквізіт повинен визначити значення обязатель них атрибутів (Документ, РодітельскійДокумент, Обєкт, ВідРасч, ДатаНачала і ДатаОкончанія) Інші атрибути та додаткові реквізити ЖР визначаються в міру необхідності Атрибути ЖР ПеріодДействія і ПеріодРегістраціі користувачем не встановлюються

Метод

Опис

* Прапор = ЖрВвестіРасчет (Обєкт, відРасч, датаНачала, датаОкончанія, [результат])

Вводить розрахунок у ЖР При введенні довгих розрахунків метод вводить в ЖР кілька розрахунків Також кілька записів може бути введено при введенні витісняють розрахунків Може бути викликаний в модулі документа або в модулі ВР У першому випадку атрибути Документ і РодітельскійДокумент приймають значення поточного документа (повертається методом ТекущійДокумент) У другому значення цих атрибутів нововведених розрахунків стають рівними відповідним значенням поточного розрахунку, тобто розрахунку, результат якого визначається Параметри методу визначають значення однойменних атрибутів вводиться розрахунку

* Прапор =жрВвестіРасчетНа Підставі (документ, (обєкт, відРасч, датаНачала, датаОкончанія, [результат])

Виконує ті ж дії, що й метод ВвестіРасчет, за тим винятком, що атрибут Документ введеного розрахунку заповнюється значенням параметра документ, що вказує на документ-підставу Атрибут РодітельскійДокумент приймає, як і в методі ВвестіРасчет, значення поточного документа

* Прапор – жрЗапісатьРасчет (Обєкт, ВР, датаНач, датаКон, [результат])

Виконує ті ж дії, що й метод ВвестіРасчет, за тим винятком, що уваги не витісняє сам себе, навіть якщо він є самовитесняющімся

* Прапор = жрЗапісатьРасчетНа Підставі (док, обєкт, ВР, датаНач, датаКон, [результат])

Виконує ті ж дії, що й метод ВвестіРасчетНаОснованіі, за тим винятком, що уваги не витісняє сам себе, навіть якщо він є самовитесняющімся

* ЖрРассчітать ()

Обчислюється результат розрахунку Результат повертається зумовленою процедурою ПровестіРасчет модуля відповідного ВР Якщо розраховується запис фіксована

або скоригована вручну і її атрибут Виправлена ​​= 1,

результат розрахунку не змінюється Розрахунок не виконаються, якщо ЖР позиціонується на записи минулого періоду •

* Прапор= ЖрВибратьЗапісі ([ДатаНач], [датаКон])

Відкриває вибірку записів ЖР, період дії яких перетинається з періодом, заданим параметрами типу Дата датаНачідатаКонЯкщо параметри опущені, то відкривається вибірка всіх розрахунків ЖР

* Прапор = ЖрВибратьПеріод

([Дата])

Відкриває вибірку записів ЖР, період реєстрації яких збігається з періодом, у якому лежить параметр методудата Якщо параметрдатаопущений, то відкривається вибірка розрахунків, зареєстрованих в поточному періоді

* Прапор = жрВибратьЗапісіПо Обєкту (обєкт, [датаНач], [датаКон])

Відкриває вибірку записів ЖР, які належать обєкту, заданому параметромобєкт, і період дії яких перетинається з періодом, заданим параметрами типу Дата датаНачідатаКонЯкщо параметри датаНачідатаКон опущені, то вибираються всі належні заданого обєкта розрахунки ЖР, період дії яких перетинається з поточним періодом

Метод

Опис

* Прапор = ЖрВибратьЗапісіПо Документу (док)

Відкриває вибірку записів ЖР, атрибут Документ яких дорівнює значенню параметра док,має тип Документ

* Прапор= ЖрВибратьПеріодПо Обєкту(Обєкт, [дата])

Відкриває вибірку записів ЖР, які належать обєкту, заданому параметромобєкт,і період реєстрації яких збігається з періодом, у якому лежить параметр дата Якщо параметр дата опущений, то відкривається вибірка розрахунків, зареєстрованих в поточному періоді

* Прапор = жрВибратьПо Значенню (ГрафаОтбора, значОтбора, пернач, перКон)

Відкриває вибірку записів ЖР з відбору, заданому символьним параметромграфаОтбора,зі значеннямзначОтбораПеріод реєстрації обираних розрахунків належить тимчасовому інтервалу, заданому параметрами пернач і перКон,мають тип РасчетнийПеріод

жрНовая ()

Створює новий запис ЖР Додавання запису до ЖР здійснюється методом Записати

жр3апісать ()

Додає або змінює поточну запис ЖР Додаванню записи передує виклик методу Нова Зміна значе ний реквізитів ЖР виконується методом УстановітьРеквізіт, що викликається до методу Записати, але після методу Нова (якщо додається нова запис) При додаванні запису в обовязковому порядку встановлюються значення реквізитів Обєкт, Документ, РодітельскійДокумент і ВідРасч Слід памятати, що метод записати не відпрацьовує задані правила перерахунку і витіснення ВР

* Прапор = жрУдалітьЗапісь ()

Видаляє поточний запис ЖР (проставляє DBF-позначку видалення запису)

жрІсправіть (новРез)

Замінює існуючий результат поточного запису ЖР на новРез, встановлюючи в атрибут Виправлена ​​значення 1 Виправлена ​​запис позначається іконкою СО Результати таких записів

не змінюються при виконанні методу ВиполнітьРасчет або

Розрахувати Параметр новРез має числовий тип

жрОтменітьІсправленіе ()

Встановлює в атрибут Виправлена ​​поточного запису ЖР значення 0

Методи модуля форми ЖР

спісокВідовТекВідиОтбора

([СпісокВідовНов])

Встановлює для інтерактивного режиму роботи доступні види відбору ЖР Нові види відбору задаються рядком спісокВідовНов, містить перелік імен граф відбору, наприклад Батько, Освіта. Повертає рядок з іменами видів отборое, доступних до виклику методу За умовчанням доступні всі задані при створенні ЖР види відбору

прапор = УстановітьОтбор (ГрафаОтбора, значеніеОтбора)

Встановлює режим відображення записів ЖР з відбору Заданому символьним параметромграфаОтбораУ ЖР будуть відображатися лише ті записи, обєкти яких мають реквізит, заданий параметром графаОтбора,наприклад Освіта, дорівнює величині, заданої параметром значеніеОтбора Тип параметразначеніеОтбора повинен збігатися з типом відповідного реквізиту обєкта Щоб знову повернутися в режим виведення всіх записів ЖР, слід зробити наступний виклик:

УстановітьОтбор (“)

Метод

Опис

прапор = ПолучітьОтбор (ГрафаОтбора, значеніеОтбора)

Повертає в символьну змінну графаОтбора поточний вид відбору, а в змінну значеніеОтбора його значення Вид відбору задається методом УстановітьОтбор Якщо відбір не встановлено (відображаються всі записи), то змінна прапор отримає значення 0

прапор = ЗакладкіОтбора (графаОтбора, [значеніеОтбора])

Встановлює режим відображення закладок відбору, заданого символьним параметром графаОтбора, відкриваючи ятати зі значенням значеніеОтбора Якщо другий параметр опущений, то активізується перша закладка Якщо перший параметр дорівнює порожній рядку, то закладки відбору не відображаються

прапор = Встановити Подання (Режим, [обєкт])

Встановлює режим виведення записів ЖР Якщо режим дорівнює:

• 1, виводяться всі записи ЖР, параметр обєкт не використовується

• 2, виводяться записи, що мають атрибут Обєкт, що дорівнює значенню параметра обєкт

• 3, виводяться записи, що мають атрибут Документ, що дорівнює значенню параметра обєкт

прапор = ПолучітьПредставленіе

(Режим, обєкт)

Повертає в параметри режим і обєкт поточні значення режиму представлення записів ЖР, заданого методом УстановітьПредставленіе Мінлива прапор прийме значення 1, якщо подання встановлено, або 0 –

в іншому випадку

флагТек = РассчітиватьПрі ОтменеІсправленія ([ФлагНов])

Встановлює, якщо флагНов = 1, режим автоматичного розрахунку записів при інтерактивній скасування ручної правки За замовчуванням флагНов = 0 і автоматичного розрахунку записів при інтерактивній скасування ручної правки не проводиться Повертає значення прапора розрахунку, чинне

в системі на момент виклику методу

Зауваження:

1 Префіксжр,спожитий з методами ЖР і його періодом, може бути довільним

2 Методи, позначені (*), застосовуються тільки з перемінними, обумовленими функцій СоздатьОбект Інші методи, якщо вони знаходяться в модулі форми ЖР і застосовуються для поточного журналу, вживаються без префікса

3 Зявляється в таблиці зміннапрапордорівнює одиниці, якщо метод виконаний вдало, і нулю в іншому випадку

Приклад 1для методу періоду ЖР Виводяться поточний, наступний і попередні періоди журналу Зарплата_2

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ЖЗ, Пертек, пров

ЖЗ = СоздатьОбект (ЖурналРасчетовЗарплата_2)

пер = жзТекущійПеріод ()

Повідомити (Поточний період: + Символ Табуляції + пер) пер = перПрібавітьПеріод (1)

Повідомити (Період після: + СімволТабуляціі + пер) пер = перПрібавітьПеріод (-2)

Повідомити (Період до: + СімволТабуляціі + пер) КонецПроцедури / / Виконати

Результат:

Поточний період: грудень 2001 Період після: січень 2002 Період до: листопад 2001

Приклад 2для методу періоду ЖР Виводяться поточний, наступний і попередні періоди реєстрації

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ЖЗ, Пертек, пров

ЖЗ = СоздатьОбект (ЖурналРасчетовЗарплата_2)

‘ЖзВибратьЗапісі () / / Позиціонуємо на першому розрахунку ЖЗ

пер = жзПеріодРегістраціі / / Або жзПеріодДействія Повідомити (Період реєстрації: + СімволТабуляціі + пер)

пер = перПрібавітьПеріод (1)

Повідомити (Період після: + СімволТабуляціі + пер) пер = перПрібавітьПеріод (-2)

Повідомити (Період до: + СімволТабуляціі + пер) КонецПроцедури / / Виконати

Результат той же, що й у прикладі 1

Приклад 3 Виводиться вигляд і уявлення виду ЖЗ Зарплата_2

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ЖЗ

ЖЗ = СоздатьОбект (ЖурналРасчетовЗарплата_2)

/ / Ідентифікатор ЖЗ

Повідомити (жзВід ()) / / Зарплата_2

/ / Синонім ЖЗ

Повідомити (жзПредставленіеВіда ()) / / Журнал заробітної плати

КонецПроцедури / / Виконати

Приклад 4У вікно повідомлень виводяться всі розрахунки ЖЗ, що відносяться до вибраного співробітнику

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем сСотр_2, ЖЗ

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2)

/ / Метод Вибрати викликає діалог для вибору елемента довідника

/ / Якщо працівник не обраний

якщо сСотр_2Вибрать (Виберіть співробітника, ФормаСпіска) = 0 тоді Попередження (Співробітник не вибрано”)

повернення

КонецЕсли

/ / Вибрано Добрецов Б Ю

ЖЗ = СоздатьОбект (ЖурналРасчетовЗарплата_2) жзВибратьЗапісіПоОбекту (сСотр_2ТекущійЕлемент ()) поки жзПолучітьЗапісь () = 1 цикл

Повідомити (” + жзОбект + СімволТабуляціі + жзВідРасч + Символ Табуляції + жзРезультат)

конецЦікла / / Поки КонецПроцедури / / Виконати

Результат:

Добрецов Борис Юрійович

Початкове сальдо

075

Добрецов Борис Юрійович

Премія коефіцієнтом

1670

Добрецов Борис Юрійович

Премія сумою

2000

Добрецов Борис Юрійович

Перерахування в банк

8444

Добрецов Борис Юрійович

ПДФО

126165

Добрецов Борис Юрійович

Оклад

2800

Добрецов Борис Юрійович

Премія 1234

3235

Приклад 5У вікно повідомлень виводяться всі розрахунки ЖЗ, що відносяться до вибраний

ному документу

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем док, ЖЗ

док = СоздатьОбект (ДокументПремія)

/ / Метод Вибрати викликає діалог для вибору документа

/ / Якщо документ не обраний

якщо докВибрать (Виберіть документ) = 0 тоді Попередження (Документ не вибраний”) повернення

КонецЕсли

ЖЗ = СоздатьОбект (ЖурналРасчетовЗарплата_2) жзВыбратьЗаписиПоДокументу (докТекущійДокумент ()) поки жзПолучітьЗапісь () = 1 цикл

Повідомити (” + жзОбект + СімволТабуляціі + жзВідРасч + СімволТабуляціі + жзРезультат)

конецЦікла / / Поки КонецПроцедури / / Виконати

Результат:

Волосків Михайло Андрійович

Премія сумою

500

Волосків Михайло Андрійович

Премія коефіцієнтом

1600

Волосків Михайло Андрійович

Премія 1234

2550

Приклад 6У вікно повідомлень виводяться всі зареєстровані в поточному періоді розрахунки ЖЗ (обєкт, ВР і результат) співробітників другого цеху

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем сСотр_2, ЖЗ, пер, підр

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2) якщо сСотр_2НайтиПоНаименованию (02 Цех, 0) = 0 тоді

Попередження (Другий цех не найден”) повернення

КонецЕсли

ЖЗ = СоздатьОбект (ЖурналРасчетовЗарплата_2) пер = жзТекущійПеріод ()

/ / Підрозділ підприємства (знайдена вище група довідника Сотруднікі_2) підр = сСотр_2ТекущійЕлемент ()

жзВибратьПоЗначенію (Батько, підр, пер, пер) поки жзПолучітьЗапісь () = 1 цикл

Повідомити (” + жзОбект + СімволТабуляціі + жзВідРасч + СімволТабуляціі + жзРезультат)

конецЦікла / / Поки КонецПроцедури / / Виконати

Результат:

Абрамова Лариса Сергіївна

Початкове сальдо

26

Абрамова Лариса Сергіївна

Оклад

2500

Абрамова Лариса Сергіївна

ПДФО

325

Абрамова Лариса Сергіївна

Перерахування в банк

2177

Приклад7 Віддаляються всі розрахунки ЖЗ, що відносяться до вибраного документу, і сам документ Записи отримують DBF-позначку видалення, а документом проставляється 1С-позначка видалення

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем док, ЖЗ

док = СоздатьОбект (ДокументПремія)

/ / Метод Вибрати викликає діалог для вибору документа

/ / Якщо документ не обраний

якщо докВибрать (Виберіть документ) = 0 тоді Попередження (Документ не вибраний”) повернення

КонецЕсли

ЖЗ = СоздатьОбект (ЖурналРасчетовЗарплата_2) жзВыбратьЗаписиПоДокументу (докТекущійДокумент ()) поки жзПолучітьЗапісь () = 1 цикл

жзУдалітьЗапісь () / / Видаляємо розрахунок (ставимо DBF-позначку видалення) конецЦікла / / Поки

докУдаліть (0) / / Видаляємо документ (ставимо 1С-позначку видалення) КонецПроцедури / / Виконати

Приклад 8Обнуляється прапор ручної правки розрахунків обраного співробітника, крім розрахунків з ВР ПреміяСум_2, для яких, навпаки, вноситься ручна правка результату Нова величина премії дорівнює 1250 руб Попутно виконується розрахунок записів, з яких зніметься прапор ручної правки

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем сСотр_2, ЖЗ, ВР

сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2)

/ / Метод Вибрати викликає діалог для вибору елемента довідника

/ / Якщо працівник не обраний

якщо сСотр_2Вибрать (Виберіть співробітника, ФормаДляВибора) = 0 тоді Попередження (Співробітник не вибрано”)

повернення КонецЕсли

/ / Вибрано Агальцов Ю А

ЖЗ = СоздатьОбект (ЖурналРасчетовЗарплата_2) жзВибратьПеріодП0Обекту (сСотр_2ТекущійЕлемент ()) ВР = ВідРасчетаПреміяСум_2

поки жзПолучітьЗапісь () = 1 цикл

якщо (жзІсправлена ​​= 1) і (жзВідРасч про ВР) тоді

жзОтменітьІсправленіе ()

//

Знімаємо прапор ручної правки результату

жзРассчітать () / /

Розраховуємо запис

КонецЕсли

якщо жзВідРасч = ВР тоді жзІсправіть (12500)

КонецЕсли конецЦікла / / Поки Попередження (Готово”)

КонецПроцедури / / Виконати

Для ілюстрації методів модуля форми ЖР увійдемо в конфігурацію, розкриємо її пункт Журнали розрахунків і в ЖЗ Зарплата_2 встановимо ще один вид (графу) відбору Освіта (рис 775)

Рис 775 У ЖЗ Зарплата_2 доступні відбори за графами Батько та Освіта

Приклад 9У формі списку ЖЗ Зарплата_2 встановлюється відбір за графою Освіта Це виконується в зумовленою процедурі прочинене модуля форми списку ЖЗ

процедура відкриття () / / Зумовлена ​​процедура перем обр, прапор, сСотр_2, сОбр_2

/ / Задаємо доступні види відбору (цей виклик може бути опущений)

ВідиОтбора (Батько, Освіта)

/ / Відображаємо закладки відбору з реквізиту Освіта ЗакладкіОтбора (Освіта)

/ / Встановимо уявлення по одному обєкту

/ / Знайдемо для цього співробітника, яка має вищу освіту сСотр_2 = СоздатьОбект (СправочнікСотруднікі_2) сОбр_2 = СоздатьОбект (СправочнікОбразованіе_2)

/ / Вибираємо вид освіти обр

прапор = сОбр_2Вибрать (Виберіть вид освіти, “) якщо прапор = 1 тоді

обр = сОбр_2ТекущійЕлемент ()

якщо сСотр_2НайтіПоРеквізіту (Освіта, обр, 1) = 1 тоді

/ / Відображаємо записи по одному обєкту УстановітьПредставленіе (2, сСотр_2ТекущійЕлемент ())

КонецЕсли КонецЕсли сСотр_2 = 0 сОбр_2 = 0

/ / Для інших процедур модуля визначимонтп

нтп = НачалоТекущегоПеріода () КонецПроцедури

Результат після відкриття форми ЖЗ см на рис 776

Рис 776 Встановлено відбір за графою Освіта і режим подання по одному обєкту

Зауваження Щоб повноцінно використовувати відбір за графою Освіта, потрібно внести відповідні зміни і в діалог форми списку ЖЗ Зарплата 2, і в мо-

дуль форми Зокрема, прапорецьдоведеться замінити на наведений

на рис 777 перемикач

Рис 777 Перемикач видів відборів

Приклад 10 Вформі списку ЖЗ Зарплата_2 виводяться тільки співробітники із заданим освітою

процедура відкриття () / / Зумовлена ​​процедура перем обр, прапор, сОбр_2, графаОтбора, значеніеОтбора

/ / Вибираємо вид освіти обр

сОбр_2 = СоздатьОбект (СправочнікОбразованіе_2) прапор = сОбр_2Вибрать (Виберіть вид освіти, “) якщо прапор = 1 тоді

обр = сОбр_2ТекущійЕлемент ()

/ / Задаємо режим виведення записів про співробітників з утворенням обр

УстановітьОтбор (Освіта, обр) КонецЕсли

/ / Контрольний висновок

якщо ПолучітьОтбор (графаОтбора, значеніеОтбора) = 1 тоді Повідомити (Встановлено відбір за графою + графаОтбора +

” зі значенням + ЗначеніеОтбора) КонецЕсли

УстановітьПредставленіе (1) / / Висновок списку співробітників

/ / Для інших процедур модуля визначимо нтп

нтп = НачалоТекущегоПеріода () КонецПроцедури / / прочинене

Результат:

Встановлено відбір за графою Освіта зі значенням Середнє

Приклад 11Вформі списку ЖЗ Зарплата_2 виводяться тільки записи, що ставляться до документа, обраному в зумовленою процедурі прочинені

процедура відкриття () / / Зумовлена ​​процедура перем док

док = СоздатьОбект (ДокументПремія)

/ / Метод Вибрати викликає діалог для вибору документа

/ / Якщо документ не обраний

якщо докВибрать (Виберіть документ) = 0 тоді Попередження (Документ не вибраний”) повернення

КонецЕсли

/ / Висновок розрахунків, породжених обраним раніше документом УстановітьПредставленіе (3, докТекущійДокумент ())

/ / Для інших процедур модуля визначимо нтп

нтп = НачалоТекущегоПеріода () КонецПроцедури / / прочинене

711&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp Приречення Е ПРОЦЕДУР И модулем Я ФОРМ И ЖУРНАЛ А розрахунків у

Наведені в табл 717

Попереднє визначення процедури модуля форми ЖР

Таблиця 717

ПрикладЗабороняється ручне виправлення результатів у всьому ЖР

/ / Процедура входить до складу модуля форми списку ЖР процедура ПріІсправленііРезультата (запис)

Попередження (Ручна правка неможлива”) СтатусВозврата (0)

КонецПроцедури

Джерело: Бартеньев О В 1С: Підприємство: програмування для всіх Базові обєкти та розрахунки на одній дискеті М: Діалог-МІФІ, 2005 464 с

Схожі статті:


Сподобалася стаття? Ви можете залишити відгук або підписатися на RSS , щоб автоматично отримувати інформацію про нові статтях.

Коментарів поки що немає.

Ваш отзыв

Поділ на параграфи відбувається автоматично, адреса електронної пошти ніколи не буде опублікований, допустимий HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*