ЗАБЕЗПЕЧЕННЯ СУМІСНОСТІ НА РІВНІ ІНТЕРФЕЙСУ програмування додатків – ANDROID ДОДАТКИ

&nbsp

У будь-який момент на ринку присутні кілька робочих версій Android, і не у всіх потенційних користувачів вашої програми обовязково буде новітня версія Вказуючи в файлі опису інформацію про сумісність програми, ви можете контролювати, в яких системах з Android буде встановлюватися ваш додаток, і, відповідно, ви гарантуєте, що ваші програми не потраплять в системи, що використовують несумісні з ними API

Ми вказували один і той же рівень API і для цільової збірки, і в поле з номером мінімальної версії SDK У такому випадку програма буде працювати тільки в системах, що мають вказаний або більш високий рівень API

Оскільки рівень API можна перевірити і під час виконання, в деяких випадках буває необхідно впровадити додаток в системах з більш низьким API, ніж той, з яким працюєте ви Доведеться тестувати систему на API з таким рівнем і використовувати методи і класи лише з більш високими рівнями API – якщо такі методи і класи доступні У таких випадках рівень API цільової складання буде вище, ніж рівень мінімальної прийнятної версії SDK

Джерело: Android Програмування на Java для нового покоління мобільних пристроїв

Схожі статті:


Сподобалася стаття? Ви можете залишити відгук або підписатися на RSS , щоб автоматично отримувати інформацію про нові статтях.

Коментарів поки що немає.

Ваш отзыв

Поділ на параграфи відбувається автоматично, адреса електронної пошти ніколи не буде опублікований, допустимий HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*