ПЕРЕДАЧА ДАНИХ ІЗ 1С В DBF-файл – ЧАСТИНА 4

Метод

Опис

прапор = ДбфНайтіПоКлючу

([Режим])

Шукає, використовуючи поточний індекс, ключ, заданий компонентами атрибута Ключ Опис методу таке ж, як і методу Знайти Використовується для будь-яких індексів

значення = ДбфПолучіть ЗначеніеПоля (ІмяПоля | номерПоля)

Повертає значення поточного запису в поле, заданим параметромімяПоля | номерПоляПараметрімяПоля це рядок з імям поля Параметр номерПоляце номер поля Виникне інформаційна помилка, якщо імяПоля (номерПоля) містить неіснуюче імя (неіснуючий номер) або якщо файл знаходиться перед першою або за останнім записом

дбфУстановітьЗначеніе Поля(ІмяПоля | номерПоля, значення)

Встановлює значення поточного запису в поле, заданим параметромімяПоля | номерПоля Подальшу інформацію про метод см в описі методу ПолучітьЗначеніеПоля Для

збереження змін, якщо не заданий режим автозбереження,

застосовується метод Записати

дбфДобавіть ()

Додає порожню запис Для її збереження в DBF-файлі застосовується, якщо не заданий режим автозбереження, метод Записати

дбфСкопіровать ()

Додає запис, який є копією поточного запису Для збереження доданої записи в DBF-файлі застосовується, якщо не заданий режим автозбереження, метод Записати

режімТек = дбфАвтоСохраненіе ([Режим])

Задає, якщо режим = 1, автоматичне збереження (АС) змінених записів бази даних У цьому випадку застосування методу Записати надмірно Для скасування змін застосовується метод Скасувати Якщо режим = 0, АС змінених записів

не виконується зміни зберігаються методом Записати

Повертає існував до виклику методу режим АС

дбф3апісать ()

Заносить зміни поточного запису в базу даних Якщо метод не застосований і не задано АС, зміна позиції файлу або його закриття призведе до втрати введених даних

дбфОтменіть ()

Скасовує запис в базу даних змін, виконаних в режимі автозбереження Не скасовує дію методу Записати

дбфУдаліть ()

Проставляє позначку видалення поточного запису

прапор = ДбфЗапісьУдалена ()

Повертає 1, якщо запис має позначку видалення, або 0 в іншому випадку

дбфВосстановіть ()

Знімає позначку видалення поточного запису

дбфОчістіть ()

Очищає поточну запис, тобто в символьне поле заноситься рядок нульової довжини, в числове 0, в логічне F, а в поле типу Дата порожня дата Зміни зберігаються, якщо задано режим автозбереження або якщо слідом за методом Очистити застосований метод Записати

чіслоЗап =

дбфКолічествоЗапісей ()

Повертає кількість записів в DBF-файлі

Метод

Опис

чіслоПолей = дбфКолічество Полів ()

Повертає число полів DBF-файлу

чіслоІнд = ДбфКолічество Індексів ()

Повертає число індексів відкритого індексного файлу

дбфОпісаніеПоля (номерПоля,

імяПоля, тип, довжина,

точндсть)

Повертає для поля, що має номер, рівний параметру номерПоля,імя, тип, довжину іточность поля у відповідні параметри методу

дбфОпісаніеІндекса (НомерІнд, імяІнд, вираз, уник, спадання, фільтр)

Повертає для індексу, що має номер, рівний параметру

номерІнд,імя, індексне вираз, прапори унікальності та спадання, а також фільтр у відповідні параметри методу Параметр уник дорівнює одиниці, якщо індекс унікальний, або нулю в іншому випадку Параметр спадання дорівнює одиниці, якщо індекс сортується за спаданням значень індексного вираження, і дорівнює нулю, якщо

по зростанню

номПоля = ДбфНомерПоля (імяПоля)

Повертає номер поля за його імені

дбфДобавітьПоле (ІмяПоля, тип, довжина, точність)

Додає в структуру DBF-файла поле, імя якого визначено символьним параметромімяПоля, а тип, довжина

і точність задаються відповідними параметрами методу

Параметрточність має сенс тільки для числового поля

Параметр типдорівнює:

• 1 або N, якщо додається числове поле

• 2 або S, якщо додається символьне поле

• 3 або D, якщо додається поле типу Дата

• 4 або L, якщо додається логічне поле

• 5 або F , Якщо додається числове поле Після додавання всіх полів вживається метод СоздатьФайл

дбфДобавітьІндекс

(ІмяІнд, вираз, уник, спадання, фільтр)

Додає в структуру індексного файлу індекс, імя якого визначено символьним параметромімяІнд, а індексне вираз, прапори унікальності, убування

і фільтр індексу задаються відповідними параметрами методу Параметривиразіфільтрмають символьний тип Сенс параметрів уникі спадання см в методі ОпісаніеІндекса Після додавання всіх індексів використовується спосіб СоздатьФайл або СоздатьІндекснийФайл

дбфСоздатьІндекснийФайл (имяфайла)

Створює індексний файлимяфайла, містить всі індекси, сконструйовані до виклику методу СоздатьІндекснийФайл методом ДобавітьІндекс Тип параметра имяфайла символьний Також індексний файл може бути створений і методом СоздатьФайл

Метод

Опис

кодСтрТек дбфКодовая Сторінка ([кодСтр])

Встановлює, якщо кодСтр = 0, Windows-кодову сторінку або DOS-кодову сторінку, якщо кодСтр = 1 Повертає існувала до виклику методу кодову сторінку

За замовчуванням кодСтр = 1

код = дбфКодОшібкі ()

Повертає код останньої помилки, що виникла при виконанні методу обєкта XBase

Зауваження:

1 ПрефіксДБФ, спожитий з методами обєкта XBase, може бути довільним

2 Фільтр індексу є логічним вираженням, складеним за правилами, викладеними в розд 9313 У індексному файлі, якщо фільтр заданий, є посилання тільки на ті записи DBF-файла, для яких вираз фільтра істинно Тоді, якщо індекс з фільтром є поточним, записи, на яких немає посилань в і ндексном файлі, користувачеві недоступні Відсутність фільтра рівнозначно фільтру, що повертає для всіх записів Т (істина)

Приклад 1 Виводяться коди (табельні номери) всіх співробітників, що мають оклад, рівний 2900 руб

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ДБФ

ОчістітьОкноСообщеній () ДБФ = СоздатьОбект (ХВаsе) дбфОткритьФайл (Salarydbf) якщо дбфОткрита () = 0 тоді

Попередження (Немає файлу salarydbf в каталозі користувача немає”) повернення

КонецЕсли

/ / Перехід в початок файлу salarydbf в даному прикладі метод може бути опущений,

/ / Оскільки після відкриття файл і так знаходиться на своєму першому записі дбфПервая ()

поки дбфВКонце () = 0 цикл

якщо дбфSalary = 2900 тоді Повідомити (дбфId)

КонецЕсли дбфСледующая ()

конецЦікла / / Поки КонецПроцедури / / Виконати

Результат:

111

209

Приклад 2 Виводяться ПІБ всіх співробітників, прізвище яких починається з букви Б

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ДБФ

ОчістітьОкноСообщеній () ДБФ = СоздатьОбект (ХВаse) дбфОткритьФайл (emploуееdbf, employeecdx)

якщо дбфОткрита () = 0 тоді

Попередження (Немає файлу employeedbf та / або файлу employeecdx

| В каталозі користувача немає ) повернення

КонецЕсли дбфТекущійІндекс (Name)

/ / Шукаємо запис, рівну або більшу символу Б якщо дбфНайті (Б, 1) = 1 тоді

поки Лев (дбфName, 1) = Б цикл Повідомити (дбфName) дбфСледующая ()

конецЦікла / / Поки інакше

Попередження

(Співробітників, прізвище яких починається на букву Б, у файлі немає”) КонецЕсли

КонецПроцедури / / Виконати

Результат:

Бараненко Іван Несторович Безверхний Ігор Петрович

Приклад 3Оклад співробітника, табельний номер (код) якого дорівнює 209, збільшується на 500 руб Для нового окладу в файл salarydbf додається запис

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ДБФ, окл

ОчістітьОкноСообщеній ()

ДБФ = СоздатьОбект (ХВаse) дбфОткритьФайл (salarydbf, salarycdx) якщо дбфОткрита () = 0 тоді

Попередження (Немає файлу salarydbf та / або файлу salarycdx

| В каталозі користувача немає )

повернення КонецЕсли дбфТекущійІндекс (IdDate) дбфКлючId = 209

/ / Шукаємо запис, велику str (209)

/ / Памятаємо, що індексне вираз це STR (Id) + DTOS (Date) якщо дбфНайтіПоКлючу (2) = 1 тоді

/ / Переміщаємося на останнє значення окладу співробітника з кодом 209 поки дбфId = 209 цикл

дбфСледующая () конецЦікла / / Поки

дбфПредидущая () / / Крок назад окл = дбфПолучітьЗначеніеПоля (Salary)

/ / Або, використовуючи атрибут: окл = дбфSalary дбфДобавіть () дбфУстановитьЗначениеПоля (Id, 209)

дбфУстановитьЗначениеПоля (Date, ТекущаяДата ()) дбфУстановитьЗначениеПоля (Salary, окл + 500)

/ / Або, використовуючи атрибути:

/ / ДбфId = 209 дбфDate = ТекущаяДата () дбфSalary = окл + 500 дбф3апісать ()

Попередження (Готово”) інакше

Попередження (Співробітника з кодом 209 у файлі немає”) КонецЕсли

КонецПроцедури / / Виконати

Приклад 4 Копіюється і записується у файл salarydbf його останній запис

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ДБФ

ОчістітьОкноСообщеній () ДБФ = СоздатьОбект (ХВаse) дбфОткритьФайл (salarydbf) якщо дбфОткрита () = 0 тоді

Попередження (Немає файлу salarydbf в каталозі користувача немає”) повернення

КонецЕсли

дбфАвтоСохраненіе (1)

//

Будемо обходитися без методу Записати

дбфПоследняя ()

//

Перехід на останній запис

дбфСкопіровать ()

//

Додаємо копію останнього запису

Попередження (Готово”)

КонецПроцедури / / Виконати

Приклад 5 Виводяться опису всіх полів та індексів файлу salarydbf

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ДБФ, ин, імяПоля, тип, довжина, точність

перем імяІнд, вираз, уник, спадання, фільтр

ОчістітьОкноСообщеній () ДБФ = СоздатьОбект (ХВаse) дбфОткритьФайл (salarydbf, salarycdx ) якщо дбфОткрита () = 0 тоді

Попередження (Немає файлу salarydbf та / або файлу salarycdx

| В каталозі користувача немає ) повернення

КонецЕсли

Повідомити (Опис полів файлу salarydbf:) для ін = 1 по дбфКолічествоПолей () цикл

дбфОпісаніеПоля (ін, імяПоля, тип, довжина, точність) Повідомити (імяПоля + ” + тип + ” + довжина + ” + точність)

конецЦікла / / Для

Повідомити (Опис індексів файлу salarydbf:) для ін = 1 по дбфКолічествоІндексов () цикл

дбфОпісаніеІндекса (ін, імяІнд, вираз, уник, спадання, фільтр) Повідомити (імяІнд + ” + вираз + ” + уник + ” + спадання + ” + фільтр)

конецЦікла / / Для КонецПроцедури / / Виконати

Результат:

Опис поля файлу salarydbf: ID 1 50

DATE 3 8 0

DOCNAME 2 15 0

DOCID 1 5 0

SALARY 1 10 2

Опис індексів файлу salarydbf: IDDATE STR (id) + DTOS (date) 0 0

Приклад 6Вміст довільного DBF-файлу виводиться в таблицю значень

Діалог форми, яка містить таблицю значень, оформимо відповідно до рис 98

Рис 98 Таблиця значень для записів DBF-файлу

У заголовку таблиці значень будемо виводити значення виразу Склад файлу + Имяфайла

яке задамо в діалозі як формулу елемента діалогу Текст

/ / Вводимо змінну модуля для її використання в діалозі перем имяфайла

процедура ПоказатьДБФ (ДБФ, имяфайла) далі

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ДБФ, прапор, папка

ОчістітьОкноСообщеній ()

/ / Відкриваємо діалог для вибору DBF-файлу

/ / Як приклад виберемо файл employeedbf

прапор = ФСВибратьФайл (0, имяфайла, папка, Виберіть файл, | * DBF) якщо прапор = 0 тоді

повернення КонецЕсли

ДБФ = СоздатьОбект (ХВаsе) дбфОткритьФайл (папка + имяфайла) якщо дбфОткрита () = 0 тоді

Попередження (Не вдалося відкрити файл + имяфайла) повернення

КонецЕсли

/ / Відобразимо DBF-файл имяфайла у таблиці значень

/ / Результат наведено на рис 99

ПоказатьДБФ (ДБФ, имяфайла) КонецПроцедури / / Виконати

/ / Виводить записи DBF-файлу имяфайла в таблицю значень процедура ПоказатьДБФ (ДБФ, имяфайла)

перем ін, імяПоля, тип, довжина, точність, номСтрокі

/ / Формуємо стовпчики таблиці значень і встановлюємо їх параметри

для ін = 1 по дбфКолічествоПолей () цикл дбфОпісаніеПоля (ін, імяПоля, тип, довжина, точність) тЗначНоваяКолонка (імяПоля, тип)

тЗначУстановитьПараметрыКолонки (ін, тип, довжина, точність,, хв (10, довжина)) конецЦікла / / Для

/ / Заголовок таблиці значень діалогу загТЗнач = Склад файлу + Имяфайла

/ / Заповнюємо таблицю значень тЗнач даними з DBF-файлу

дбфПервая () / / Переходимо на перший запис файлу

номСтрокі = 0

поки дбфВКонце () = 0 цикл / / Ще не досягнуто кінець файлу

номСтрокі = номСтрокі + 1 тЗначНоваяСтрока (номСтрокі)

для ін = 1 по дбфКолічествоПолей () цикл тЗначУстановітьЗначеніе (номСтрокі, ин, дбфПолучітьЗначеніеПоля (ін))

конецЦікла / / Для дбфСледующая ()

конецЦікла / / Поки КонецПроцедури / / ПоказатьДБФ

Рис 99 Файл employeedbf в таблиці значень

Зауваження   Подібного роду процедуру завжди зручно мати під рукою для оперативного перегляду використовуваних DBF-файлів Нагадаємо, що таблицю значень також можна відобразити, застосувавши метод ВибратьСтроку

Приклад 7Виводяться коди співробітників, оклад яких більше 3000 руб Для отримання результату на додаток до існуючого створюється індекс з виразом Salary і фільтром Salary> 3000

перем имяфайла

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем ДБФ, прапор, папка

ОчістітьОкноСообщеній ()

ДБФ = СоздатьОбект (ХВаsе) дбфОткритьФайл (salarydbf) якщо дбфОткрита () = 0 тоді

Попередження (Немає файлу salarydbf в каталозі користувача немає”) повернення

КонецЕсли

/ / Індекс IdDate забезпечить сортування за датою в межах заданого коду співробітника дбфДобавітьІндекс (IdDate, str (Id) + dtos (Date), 0, 0, “)

/ / Індекс Salary забезпечить сортування по окладу дбфДобавітьІндекс (Salary, Salary, 0, 0, Salary> 3000) дбфСоздатьІндекснийФайл (Salarycdx) дбфТекущійІндекс (Salary)

дбфПервая () / / Перехід в початок файлу

/ / Висновок результату Доступні тільки ті записи, у яких Salary> 3000

Повідомити (Коди співробітників, оклад яких більше 3000 руб”)

поки дбфВКонце () = 0 цикл / / Ще не досягнуто кінець файлу Повідомити (Рядок (дбфId) + Символ Табуляції +

“(Оклад співробітника дорівнює + Рядок (дбфSalary) + крб))

дбфСледующая () конецЦікла / / Поки имяфайла = salarydbf;

ПоказатьДБФ (ДБФ, имяфайла) / / Код процедури ПоказатьДБФ див вище КонецПроцедури

Результат роботи процедури ПоказатьДБФ см на рис 910

Результат:

Коди співробітників, оклад яких більше 3000 руб

301 (оклад співробітника дорівнює 3100 руб)

122 (оклад співробітника дорівнює 3200 руб) 2010 (оклад співробітника дорівнює 3200 руб)

302 (Оклад співробітника дорівнює 3200 руб)

303 (Оклад співробітника дорівнює 3200 руб)

Рис 910 Файл salarydbf під дією забезпеченого фільтром індексу Salary

9323 ВИРАЖЕННЯ ІНДЕКСУ І ФИЛЬТРА

Вирази, що вживаються в методі-ДобавітьІндекс, для індексу і фільтра, можуть містити в якості операндів імена полів, константи і виклики функцій Аргументами функцій, застосовуваних у виразах, можуть також бути імена полів, константи і виклики, функцій Наприклад, у методі

дбфДобавітьІндекс (Depart, trim (str (ParentId)) + Name, 0, 0, “)

індексне вираз містить функції TRIM, STR та імена полів DBF-файлу ParentId і Name, а в методі

дбфДобавітьІндекс (Salary, Salary, 0, 0, Salary> 3000)

вираз фільтра включає імя поля Salary та числову константу 3000

В якості логічних констант використовуються Т і F для позначення відповідно констант істина і брехня

Константи типу Дата задаються в фігурних дужках

Регістр написання операндів виразу не має значення

Вираз індексу може мати числовий, символьний, логічний тип або тип Дата

Вираз фільтра, якщо задано, повинно мати логічний тип

У виразах індексу і фільтра можуть застосовуватись наведені в табл 97 операції (вони розташовані в таблиці в порядку убування їх пріоритету операції з одним пріоритетом розміщуються в одному рядку таблиці)

Операції виразів індексу і фільтра

Таблиця 97

Операції

Значення

Арифметичні операції

Унарний мінус

** або ^

Піднесення до степеня

*,/

Множення, ділення

+,-

Додавання, віднімання

Символьні операції

+

Обєднання (конкатенація)

Обєднання 2 (конкатенація 2)

Операції відносини

=, &lt&gt або #,&lt,&gt,&lt=,&gt= $

Дорівнює, не дорівнює, менше, більше, менше або дорівнює, більше або дорівнює, містить

Логічні операції

NOT

Логічне НЕ (заперечення)

AND

Логічне І

OR

Логічне АБО

Зауваження:

1 Всі операції, крім Унарні мінуса, є двомісними (бінарними), тобто вживаються між двома операндами

2 Вирази обчислюються зліва направо в порядку, що визначається пріоритетом операцій Частина подвираженія, укладена в круглі дужки, обчислюється в першу чергу Більш докладно про обчисленні виразів див розд 26

3 Унарний мінус має більший пріоритет, ніж інші арифметичні (та інші) операції Наприклад, вираз

-2**2

поверне, так само як і вираз (-2) ** 2

число 4

4 Символьна операція -, на відміну від операції +, переміщує завершальні прогалини першого операнда в кінець результату, наприклад, вираз

“3 п + боявся

поверне рядок 3 п боявся, а вираз 3 п Боявся

рядок 3 прогалини.

5 Операція $ застосовується тільки з символьними операндами Вираз відносини з операцією $ поверне Т, якщо перший операнд вираження є підрядком другого, або F в іншому випадку Наприклад вираз

“БВ $ АБВГ

поверне Т, а вираз БГ $ АБВГ

поверне F.

6 На відміну від 1С у виразах індексу і фільтра не можна змішувати символьні і арифметичні операнди Так, замість

“АБС + 2

щоб отримати рядок АБС2, потрібно вжити вираз АБС + Trim (str (2))

або вираз АБС + Str (2 , 1)

У виразах індексу і фільтра використовуються наведені в табл 98 функції

Таблиця 98

Функції для виразів індексу і фільтра

Функція

Що повертає

Тип результату

DATE()

Поточну дату, наприклад 01/14/02

Дата

DAY (дama)

День місяця, заданого параметром дата

Число

DTOC (дama)

Символьне подання дати, заданої параметром дата

Рядок

DTOS (дama)

Символьне подання дати, заданої параметром дата, у вигляді РРРРММДД

&quot

IIF (лВир, вир1, вир2)

Результат виразу вир1, якщо істинно логічне вираження лВир, або результат вираження вир2

в іншому випадку Виразивир1 і вир2 можуть бути довільного типу

Збігається з типом

вир1 або вир2

LTRIM (cтрокa)

Рядок, в якої вилучені провідні прогалини параметра рядок

Рядок

Функція

Що повертає

Тип

результату

MONTH (дaтa)

Номер місяця в році, заданого параметромдата

Число

STOD (cmpoкa)

Дату у форматі ГПТММДД

Дата

STR (число, [Довжина], [ДЕССА])

Символьне подання параметрачисло у вигляді рядка довжиноюдовжина,містить ДЕССА десяткових символів Якщо параметри довжина і ДЕССА опущені, то результуюча рядок має 10 символів і не містить десяткового частини Якщо опущений параметр ДЕССА, то результат також не містить десяткового частини

Рядок

SUBSTR (рядок, начПоз, [чіслоСім])

Підрядок параметрарядок,що починається з позиції начПоз і містить чіслоСім наступних символів Якщо останній параметр опущений, то результатом будуть всі символи

від позиціїначПоз до кінця рядка рядок

&quot

TIME()

Поточний час у форматі ГГ: ММ: СС

&quot

TRIM (рядок)

Рядок, в якої вилучені завершальні прогалини параметра рядок

&quot

UPPER(Рядок)

Рядок, перетворену у верхній регістр

&quot

VAL (рядок)

Числове представлення параметрарядок

Число

YEAR (дата)

Номер року, заданого параметром дата

&quot

Зауваження  Параметри функцій є виразами Причому параметр дата є вираженням типу Дата параметр рядок символьний вираз параметри число, довжина, ДЕССА, начПоз і чіслоСім числові вирази

Приклади вживання функцій наведено в табл 99

Таблиця 99

Приклади виклику функцій для виразів індексу і фільтра

Приклад виклику

Результат

Тип

day(date())

14

Числовий

month(date())

1

&quot

year(date())

2002

&quot

time()

16:08:46

Символьний

dtoc(date())

01/14/02

&quot

dtos(date())

20020114

&quot

k = 5

IIF(k  &gt 8, 2 * 3, &quotA&quot + &quotB&quot)

6

Числовий

k = 9

IIF(k  &gt 8, 2 * 3, &quotA&quot + &quotB&quot)

AB

Символьний

ltrim(&quot       ABC&quot)

ABC

&quot

trim(&quot     ABC     &quot) + &quotD&quot

ABCD

&quot

Приклад виклику

Результат

Тип

str(5234)

5

&quot

str(5234, 5)

5

&quot

str(5234, 6, 4)

52340

&quot

substr (Небокрай, 3, 3)

бос

&quot

substr (Hебосклон, 5)

схил

&quot

upper (Небокрай)

Небосхилі

&quot

va1 (Небокрай)

0

Числовий

val(&quot-123&quot)

-123

&quot

val(&quot+432&quot)

432

&quot

val(&quot13e+2&quot)

130

&quot

1 Обєкт XBase підєднується до DBF-файлу в режимі монопольного доступу

2 Щоб індексний файл відповідав своєму DBF-файлу, необхідно відкривати перший разом з DBF-файлом Тоді зміни в DBF-файлі автоматично викличуть необхідні зміни індексного файлу

3 Якщо якийсь час DBF-файл редагувався при закритому індексному файлі, то, відкриваючи останній, слід виконати його переіндексацію

4 Атрибут Ключ обєкта XBase використовується для завдання операндів індексного вираження

5 Для пошуку по складеному ключу слід використовувати метод НайтіПоКлючу натомість методу Знайти

6&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp Для перегляду знаходяться в роботі DBF-файлів корисно мати процедуру, переносить записи файлу в таблицю значень Виведення таблиці значень можна здійснити як в однойменний елемент діалогу, так і у вікно, що відкривається методом ВибратьСтроку

Джерело: Бартеньев О В 1С: Підприємство: програмування для всіх Базові обєкти та розрахунки на одній дискеті М: Діалог-МІФІ, 2005 464 с

Схожі статті:


Сподобалася стаття? Ви можете залишити відгук або підписатися на RSS , щоб автоматично отримувати інформацію про нові статтях.

Коментарів поки що немає.

Ваш отзыв

Поділ на параграфи відбувається автоматично, адреса електронної пошти ніколи не буде опублікований, допустимий HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*