ВІДОМОСТІ ДЛЯ БУХГАЛТЕРСЬКОГО ОБЛІКУ ЗАРПЛАТИ

Ці відомості нам надасть запит, який обчислює в заданому періоді для кожної господарської операції сумарні значення результатів відносяться до неї розрахунків

Запит запустимо з обробки Проба Для перегляду результатів запиту вивантажимо його в таблицю значень

/ / Формує та виконує запит за господарськими операціями,

/ / Підсумовуючи належні до них результати

/ / Параметр зХозОп типу Запит є вхідним / вихідним

функція ЗапрХозОп (зХозОп)

перем текстЗапХозОп / / Зміст запиту перем ЖЗ, нтп, КТП

ЖЗ = СоздатьОбект (ЖурналРасчетовЗарплата_2)

/ / Початок і кінець поточного періоду ЖЗ нтп = жзНачалоТекущегоПеріода () КТП = жзКонецТекущегоПеріода () текстЗапХозОп =

| Період з нтп по КТП / / Період запиту

/ / Змінні запиту

| ХозОп = журналРасчетовЗарплата_2ХозОп

| Рез = журналРасчетовЗарплата_2Результат

/ / Функція запиту

| Функція сумХозОп = сума (різ)

/ / Задаємо порядок вибірки даних

| Угруповання хозОп порядок хозОпНаіменованіе ;

/ / Виконуємо запит і повертаємо 1 у випадку удачі, або 0, якщо є проблеми повернення зХозОпВиполніть (текстЗапХозОп)

КонецФункции / / ЗапрХозОп

/ / Запускає запит зХозОп про господарські операції і вивантажує

/ / Його результат для подальшого перегляду в таблицю значень тЗнач

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем зХозОп, тЗнач

/ / Створюємо обєкти зХозОп і тЗначзХозОп = СоздатьОбект (Запит) якщо ЗапрХозОп (зХозОп) = 0 тоді

повернення / / Запит не вдався

КонецЕсли

/ / Створюємо обєкт тЗнач для проміжної демонстрації вибірки запиту тЗнач = СоздатьОбект (ТабліцаЗначеній)

/ / Вивантажуємо всі змінні запиту в таблицю значень тЗнач

/ / Для його попереднього перегляду зХозОпВигрузіть (тЗнач, 1)

/ / Перегляд Таблиці значень

тЗначВибратьСтроку (, Запит про господарські операції в таблиці значень) КонецПроцедури / / Виконати

Результат наведено на рис 782

Рис 782 Розподіл розрахунків за господарськими операціями

Наявна в тексті запиту рядок-функція

| Функція сумХозОп = сума (різ)

задає в результуючій таблиці поле сумХозОп, в яке для кожної групи, а угруповання виконується по змінній запиту хозОп,заноситься сума результатів всіх розрахунків, віднесених на поточну господарську операцію

Код, що повторює дії функції сумХозОп, може бути таким:

/ / Повертає в заданому періоді для заданої господарської операції хозОп

// суму результатів відносяться до неї розрахунків функція сумХозОп2 (хозОп, ЖЗ, нтп)

жзВибратьПеріод (НТП)

схо = 0 / / Шуканий результат поки жзПолучітьЗапісь () = 1 цикл

якщо жзХозОп = хозОп тоді

схо = схо ​​+ жзРезультат КонецЕсли

конецЦікла / / Поки повернення схо

КонецФункции / / сумХозОп2

Запустимо функцію сумХозОп2 для всіх господарських операцій поточного розрахункового періоду з обробки Проба Перелік господарських операцій нам дасть запитзХозОп

// Формує список використаних у поточному періоді ЖЗ господарських операцій

/ / Викликає потім функцію сумХозОп2 для кожної господарської операції

/ / І друкує повернутий функцією результат

процедура Виконати () / / Повязана з кнопкою Пуск обробки Проба перем зХозОп, текстЗапХ / / Зміст запиту

перем ЖЗ, нтп, КТП, сумРез ОчістітьОкноСообщеній ()

/ / Створюємо обєкти зХозОп і ЖЗ

зХозОп = СоздатьОбект (Запит)

ЖЗ = СоздатьОбект (ЖурналРасчетовЗарплата_2)

/ / Початок і кінець поточного періоду ЖЗ нтп = жзНачалоТекущегоПеріода () КТП жзКонецТекущегоПеріода () текстЗапХ =

| Період з нтп по КТП / / Період запиту

/ / Змінна запиту

[ХозОп = журналРасчетовЗарплата_2ХозОп

| Угруповання хозОп порядок хозОпНаіменованіе ;

/ / Виконуємо запит і повертаємо 1 у випадку удачі, або 0, якщо є проблеми якщо зХозОпВиполніть (текстЗапХ) = 0 тоді

повернення / / Запит не вдався КонецЕсли

всього = 0

поки зХозОпГруппіровка (хозОп) = 1 цикл

сумРез = сумХозОп2 (зХозОпхозОп, ЖЗ, нтп) всього = всього + сумРез

Повідомити (Сума результатів по операції + СокрП (зХозОпхозОп) + дорівнює + сімволТабуляціі + сумРез)

конецЦікла / / Поки

Повідомити (Всього по всіх операціях: + всього) КонецПроцедури / / Виконати

Результат:

Сума результатів по операції 2013000 дорівнює

55

Сума результатів по операції 2013001 дорівнює

61793

Сума результатів по операції 2017002 дорівнює

136426

Сума результатів по операції 2300100 дорівнює

91301

Сума результатів по операції 2300111 дорівнює

33550

Сума результатів по операції 2300112 дорівнює

9600

Всього по всіх операціях: 2098921

Якщо потрібно переглянути окремі складові кожної групи із зазначенням обєкта, текст запиту потрібно сформувати наступним чином:

текстЗапХозОп =

| Період з нтп по КТП / / Період запиту

/ / Змінні запиту додаємо змінну співр

| Співр = журналРасчетовЗарплата_2Объект

| ХозОп = журналРасчетовЗарплата_2ХозОп

| Рез = журналРасчетовЗарплата_2Результат

/ / Функція запиту

| Функція сумХозОп = сума (різ)

/ / Задаємо порядок вибірки даних

| Угруповання хозОп порядок хозОпНаіменованіе

| Угруповання рез ; / / Додана рядок

Тоді в таблиці результатів ми будемо спостерігати наведені на рис 783 дані

Рис 783 Фрагмент результату запиту для групи хозОп = 20130000

Тепер, коли виконані розрахунки і випущені всі необхідні документи, можна перейти до наступного розрахункового періоду Це можна зробити інтерактивно, вибравши на панелі інструментів діалогу форми списку ЖЗ Зарплата 2 іконку У цьому випадку будуть відпрацьовані супроводжуючі зміну системні дії, зумовлена ​​процедура глобального модуля ПріСменеРасчетногоПеріода і, отже, додана

нами в глобальний модуль процедура ФіксіроватьСменуРП (розд 7363) У результаті її виконання в документі Початок періоду № 1 зявиться нова запис, що нагадує про події подію (рис 784)

Рис 784 Новий розрахунковий період

Згадаймо, що архівні записи ЖЗ (крім фіксованих) мають інший колір фону супроводжуючих їх іконок блакитний Змінюється і фон іконок в журналі документів: іконки, супроводжуючі документи, відповідні архівним розрахунками, розташовуються на темно-синьому тлі

У новому періоді немає поки що жодного розрахунку Але не слід поспішати з їх введенням, оскільки період відкриває новий рік і швидше за все для нього не визначені використовувані довідником Сотруднікі_2 календарі і свята Тому випереджу введення розрахунків завданням свят, а слідом виконаємо автозаповнення календарів Всі необхідні кошти для виконання цих дій у нас Тобто, доступ до них здійснюється за допомогою пунктів Календарі й Свята, розташованих в колонці Календарі меню інтерфейсу Учень

713 ВИСНОВКИ

1 ЖР складається із записів, званих розрахунками вони потрапляють в журнал в результаті проведення відповідних документів

2 Розрахунки можуть бути обовязковими, додатковими, витісняють, довгими, перерахунками, залежними і звичайними Корисно контролювати, чи мають обєкти ЖЗ всі обовязкові розрахунки

3 Довгі розрахунки можуть існувати тільки в документах У ЖЗ довгий розрахунок розбивається на відповідне число звичайних розрахунків

4 В опис групи ВР слід поміщати інформацію про програми, в яких група використовується

5 Перенесення даних в 1С з інших програм можна виконати, вживаючи обєкти типу XBase

6 Основне призначення обєктів типу Календар і Свята надавати дані для обчислення числа робочих годин і днів у заданому часовому інтервалі

7 Складні документи, журнали і обробки 1С, що враховують багато випадків життя, доцільно замінювати на аналогічні за призначенням, що відповідають потребам підприємства простіші і, отже, ефективні програми

8 У вікні завдання властивостей документа, що вводить розрахунки, потрібно активізувати прапорець Розрахунок

9 Методи ВвестіРасчет і ЗапісатьРасчет можуть бути викликані тільки в модулях документів, що вводять розрахунки Викликати ці методи в модулях інших обєктів, наприклад в модулі форми списку ЖЗ або в модулі звіту (обробки), не можна

10 Розрахунки одного обєкта розташовуються в ЖЗ в порядку черговості їх виконання

11 Команда проведення документа при виконанні перепроведення відслідковує всі можливі відбулися в документі зміни

12 Для оновлення самовитесняющего розрахунку при його повторному введенні іншим документом замість методу ЗапісатьРасчет використовується метод ВвестіРасчет

13 Правила перерахунку обнуляют значення атрибута Розрахована у залежних розрахунків

14 Правила перерахунку не спрацьовують при розрахунку записи в результаті вибору пункту меню Розрахувати запис

15 Розбиваючи довгий розрахунок на частини, 1С зберігає обчислений відповідно до документа, що породжує розрахунок, результат для кожної з частин розбиття

16 Якщо в результаті витіснення розрахунок розбивається на до частин, то кожна з цих частин успадковує загальний результат, тобто загальний результат вихідного розрахунку збільшується в до раз, що входить в протиріччя з документом який створив розрахунок

17 Попереднє визначення процедури модуля форми ЖР дозволяють ефективно управляти правами доступу користувачів

Ефективність функціонування системи оцінюватимемо швидкодією програм, тимчасовим проміжком, необхідним для введення, редагування даних, пошуку помилок і отримання результату, якістю користувача інтерфейсу, надійністю обчислень і ступенем захищеності даних

На перший погляд ми не можемо вплинути на ці характеристики, оскільки вони закладені в систему її розробниками Це дійсно так, якщо експлуатувати систему як вона є Але тепер, коли ми розуміємо її вузькі ланки, знаємо, як їх перетворити, і вміємо робити це, деякі параметри ефективності можна поліпшити

Частково ця задача вирішена Так, програми розрахунку зарплати, формування розрахункових листків і відомостей перерахувань в банк, які ми розмістили в модулі форми списку ЖЗ Зарплата_2 і привели розд 7171-7173, працюють істотно швидше, ніж аналогічні вбудовані в 1С процедури Це досягнуто за рахунок втрати універсальності, але нам вона в нашій задачі і не потрібна

У цьому напрямку зацікавлені користувачі можуть зробити і інші продуктивні кроки

Інший спосіб підвищення швидкодії видалення з конфігурації непотрібних вам обєктів Відразу це може не вийти Так, якщо ви хочете видалити ВР ОплатаБЛ_Северн (лікарняний для північних регіонів), то система видасть попередження Обєкт не може бути видалений, а у вікні повідомлень виведе наступні текст:

Даний обєкт використаний в: ПравилоПерерасчетаОсновныеУдержания ПравилоПерерасчетаБольничныеЛисты ПравилоПерерасчетаНДФЛ_по_13

Однак після усунення обєкта з цих правил видалення ВР ОплатаБЛСеверн стане можливим

Джерело: Бартеньев О В 1С: Підприємство: програмування для всіх Базові обєкти та розрахунки на одній дискеті М: Діалог-МІФІ, 2005 464 с

Схожі статті:


Сподобалася стаття? Ви можете залишити відгук або підписатися на RSS , щоб автоматично отримувати інформацію про нові статтях.

Коментарів поки що немає.

Ваш отзыв

Поділ на параграфи відбувається автоматично, адреса електронної пошти ніколи не буде опублікований, допустимий HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

*